Build errors in Qt5.5.1 ( android )



  • I am getting following erros :

    errors

    okay here is my setup :

    linux mint 32-bit , qt5.5.1(android) . android-ndk-r11c (i downloaded the zip and just extracted it in home folder )

    I am also getting this error

    :-1: error: Unknown module(s) in QT: webengine
    

    this application works fine on desktop GCC 32-bit .


  • Lifetime Qt Champion

    Hi,

    QtWebEngine is not available for Android (see here. It's also valid for QtWebKit. If you just need to show html content then the QtWebView module is likely to interest you.

    Hope it helps



  • what about those android errors ?

    I just checked my tools -> options -> build & run and saw

    (!) red symbol in front of android armv7 , armv5 and x86 .

    no compiler can produce code for this qt version

    i installed : g++-arm-linux-gnueabihf but still error persist

    do i need other compiler for it ? If yes which one



  • This post is deleted!

  • Lifetime Qt Champion

    Can you check what compiler got installed with your NDK ? AFAIR, by default not all compilers are installed.

    Thus the missing architectures is a normal warning. If you want to run your application on an x86 android, you'll have rebuild Qt for it.



  • Hey @SGaist these are all the steps i did !!

    1. downloaded Qt 5.5 android offline version ( yes i am using 32-bit OS so no choice for me )

    2. chmod +x and then ./qt..... and followed the instructions next next . Selected all the modules ( select all )

    3. i already had android SDK and android studio . I then downloaded android NDK android-ndk-r11c . I just unzipped it in home directory

    4. openede Qt->tools->options->Android pointed the JDK , SDK and NDK locations ( yes i checked on build toolchains )

    That's all !!


  • Lifetime Qt Champion

    Check in the ndk whether you have gcc 4.8 available IIRC there was a change with r11.


Log in to reply