The application was unable to start correctly 0xc000007b



  • Hello everyone,
    I am developing an application using Qt5.8 and Qwt6.1.3 with Visual Studio on a Windows 10 platform.

    I used windeployqt to generate an exe file from my solution, which always worked without any problems in the past. However, this time it failed and I got the error message in the title when I tried to run the program by double-clicking on the generated exe file. I think the problem is caused by the presence of Qwt. Because in the earlier versions of my program I did not use Qwt and everything ran smooth. I tried copying the qwt.dll to fix the problem, but it did not make a difference.
    How can I fix this problem? Thanks in advance.



  • By the way, some more information:
    In the project properties on Visual Studio, I added
    "$(QTDIR)\Qwt-6.1.3\include" under Additional Include Directories,
    "$(QTDIR)\Qwt-6.1.3\lib" under Additional Library Directories,
    "qwt.lib" under Additional Dependencies and QWT_DLL under Preprocessor definitions.
    To generate the exe file, I (as always) followed the instructions on https://github.com/daviddrell/visualsc/wiki/How-to-Deploy-a-Qt-5-Application-for-Windows
    In step 4 of the instructions I copies qwt.dll under the application directory, because it was missing. but it didnt help solve the problem.


  • Lifetime Qt Champion

    Hi,

    You should use Dependency Walker to check whether you have missing dependencies for your application (e.g. some Qwt stuff).



  • Hello @SGaist,
    I followed your advice and it worked. Apparently the Qt5PrintSupport.dll and Qt5OpenGL.dll files were missing. I copied them to the application directory and it worked.
    Thank you very much.



Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.