Deploying program error with QT everywhere



  • We solved previous problem with compiling qt everywhere. I got another problem so here it is.
    When trying to deploy my test program to onlinuxino A13 board with debian installed am getting this error>
    ZN7QWidget8qwsEventEP8QWSEvent
    Application finished with exit code 127..

    Found a few links in another forums but no one gave me a solution.
    Would anyone know where is the problem??

    I have now try following not sure i it was good thing to do but looks it takes me to the next step
    sync libraries to target
    rsync -rtvpl /usr/local/qt/ root@192.168.1.109:/usr/local/qt/
    edit in target
    Add some environment variables to by adding the following lines to /etc/environment.

    LD_LIBRARY_PATH=/usr/local/qt/lib
    QTDIR=/usr/local/qt
    QWS_MOUSE_PROTO=tslib:/dev/input/event2
    QWS_DISPLAY=LinuxFB:mmWidth=310:mmHeight=190

    but now the output in target says> missing libc6.so of version 2.15
    even after sudo apt-get install libc6 still the same.

    any ideas?


  • Lifetime Qt Champion

    Hi,

    If you call ldd on your executable on your target, what do you get ?



  • This post is deleted!


  • @SGaist olimex@a13-OLinuXino-Micro:~$ ldd /home/olimex/untitled5
    /home/olimex/untitled5: /lib/arm-linux-gnueabihf/libc.so.6: version GLIBC_2.15' not found (required by /usr/local/qt/lib/libQtCore.so.4) /home/olimex/untitled5: /lib/arm-linux-gnueabihf/libc.so.6: versionGLIBC_2.15' not found (required by /usr/local/qt/lib/libQtNetwork.so.4)
    libQtGui.so.4 => /usr/local/qt/lib/libQtGui.so.4 (0xb688b000)
    libQtCore.so.4 => /usr/local/qt/lib/libQtCore.so.4 (0xb662a000)
    libstdc++.so.6 => /usr/lib/arm-linux-gnueabihf/libstdc++.so.6 (0xb6571000)
    libgcc_s.so.1 => /lib/arm-linux-gnueabihf/libgcc_s.so.1 (0xb654d000)
    libc.so.6 => /lib/arm-linux-gnueabihf/libc.so.6 (0xb6466000)
    /lib/ld-linux-armhf.so.3 (0xb6f1d000)
    libQtNetwork.so.4 => /usr/local/qt/lib/libQtNetwork.so.4 (0xb63be000)
    libpthread.so.0 => /lib/arm-linux-gnueabihf/libpthread.so.0 (0xb63a2000)
    libm.so.6 => /lib/arm-linux-gnueabihf/libm.so.6 (0xb6337000)
    libdl.so.2 => /lib/arm-linux-gnueabihf/libdl.so.2 (0xb632c000)
    librt.so.1 => /lib/arm-linux-gnueabihf/librt.so.1 (0xb631e000)


  • Lifetime Qt Champion

    Looks like you are using a sysroot for building that doesn't match the one from your target.



  • @SGaist not sure if I fully understand, so what should I do? set somwhere sysroot?
    I found settings in QT creator for sysroot, is that what you mentioned?
    0_1520163093643_Screenshot from 2018-03-04 12-25-43.png


  • Lifetime Qt Champion

    No, I mean that you should cross-compile Qt using a sysroot that matches the one from your device.



  • @SGaist do you mean qt creator or qt everywhere? if qt everywhere than here is what I used for configure and make>
    Last configuration used for compiling qt everywhere

    make clean; ./configure -embedded arm -prefix /usr/local/qt -little-endian -no-qt3support -no-cups -no-largefile -optimized-qmake -no-openssl -nomake tools -nomake examples -no-webkit -opensource -confirm-license

    make used> make -j 5


  • Lifetime Qt Champion

    Not Qt Creator, it's just the IDE and you don't need to cross-compile it unless you plan to run in on your target.

    How did you install your cross-compiler ?



  • Iam now a litle bit confused.. you say not the qt creator but IDE... isnt QT equals IDE???


  • Lifetime Qt Champion

    No, Qt Creator is the name of the cross-platform IDE the Qt Company is developing for developers. Qt itself is a pretty large framework.



  • @SGaist Hi, still trying to make it work whenever I have a little bit time. Iam trying different versions of qt everywhere. Also would have a question, what is the differene between qt-everywhere and qt-embedded? is it only about different name or there is something else?


  • Lifetime Qt Champion

    If you are referring to the package name, yes. Qt Embedded was meant for devices without X server providing QWS. Qt everywhere is for all supported devices.



  • @SGaist Next test>
    I have no package none-gnueabi so I deleted the "none" from
    mkspecs/qws/linux-arm-gnueabi-g++/qmake.conf

    the problem i thing could be still that in qt creator i can see the name of the
    compiler is
    arm-linux-gnueabi-g++ in my host system
    but the one that I can select in qt-everywhere ...mkspecs/qws/ is
    linux-arm-gnueabi-g++

    anyway Iam going to try to configure and make

    ./configure -embedded arm -prefix /usr/local/qt4-7.3 -little-endian -no-qt3support -no-cups -no-largefile -optimized-qmake -no-openssl -nomake tools -nomake examples -no-webkit -opensource -confirm-license -xplatform qws/linux-arm-gnueabi-g++

    make
    make install

    compiled and installed
    QT creator showing on run
    bash: /home/olimex/untitled8: No such file or directory
    Application finished with exit code 127.

    and if I try create non qt in qt creator like standard console application everything is ok i can build and deploy on target.

    back to qt application, if I try ldd on executable on target I get nothing...? Somehow is the qt-everywhere not working... I thign... Any ideas?



  • @SGaist There is also one thing I found in settings for the compiler there is parametr arm-linux-generic-32-bit itsnt this the problem? should not be there something like i386 or different? The board onlinuxino with armv7 is not 32bit..so?


  • Lifetime Qt Champion

    That's the cross-compiler, it indicates the target for which it will compile your application.



  • @SGaist I know its indicating the target but my target is not 32bit as far as I know.
    armv7 is not 32 or 64. Thats what I have read in different forum. So what I ask is
    "should not be there something like i386 or different?" in the compiler settings?

    And when I try to compile qt-everywhere version 4.7.3 with compiler arm-linux-gnueabi-cpp and try to run it on target it gives me output

    bash: /home/olimex/untitled11: No such file or directory
    Application finished with exit code 127.


  • Lifetime Qt Champion

    What does file /home/olimex/untitled11 tell you ?

    i386 is for Intel/AMD processor. ARM is also available in 32 and 64bit architecture.

    What is your target board exactly ?



  • @SGaist
    What you mean by "What does file /home/olimex/untitled11 tell you ?"
    the ouptut when I call it is bash: /home/olimex/untitled11: No such file or directory
    Application finished with exit code 127.

    Here is the Board

    FEATURES

    A13 Cortex A8 processor at 1GHz, 3D Mali400 GPU
    256 MB RAM (128Mbit x 16)
    5VDC input power supply with own ICs, noise immune design
    1 USB host
    1 USB OTG which can power the board
    SD-card connector for booting the Linux image
    VGA video output
    LCD signals available on connector so you still can use LCD if you disable VGA/HDMI
    Audio output
    Microphone input pads (no connector)
    1 User key
    4 Mount holes
    UEXT connectorfor connecting additional UEXT modules like Zigbee, Bluetooth, Relays, etc
    GPIO connector with 68/74 pins and these signals:
        17 for adding NAND flash;
        22 for connecting LCDs;
        20+4 including 8 GPIOs which can be input, output, interrupt sources;
        3x I2C;
        2x UARTs;
        SDIO2 for connecting SDcards and modules;
        5 system pins: +5V, +3.3V, GND, RESET, NMI
    Dimensions: 100 x 85 mm (3.950x3.350'')
    Optional low-cost 7" LCD with touchscreen
    

    https://www.olimex.com/Products/OLinuXino/A13/A13-OLinuXino-MICRO/open-source-hardware


  • Lifetime Qt Champion

    Then it means that the file wasn't copied over to the target.


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.