Qt 5.9.1 : Android build SDK is empty



  • Hi; I'm using Linux Deepin 15.4 and Qt 5.9.1. I set Android Sdk on Qt Creator like this:
    Qt->Devices->Android
    Then I created and build a QtQuickControls2 app and I get this error:

    Build failed
    Warning: Android platform 'android--1' does not exist in SDK.
    Building the android package failed!
    

    Because Android build SDK is empty like this:
    Android build SDK
    I saw this answer, but it is not working for Qt 5.9.1. Can you help me? Thanks.



  • Problem solved.
    I was use older Qt version and it doesn't need Apache Ant. But Qt 5.9.1 needs Apache Ant.
    I installed Apache Ant like this for Linux:

    sudo apt-get install ant
    


  • I had the same problem under Windows 10 - installing Apache Ant 1.9.9 and setting it in QtCreator solved it. Thanks.



  • Could you select api lower than 25?After I update to android studio 2.3.3 and Qt5.9.1, the only api I could select is 25

    I put the details at here


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.