"QtQml.Models" version 2.0 is not installed - QML Demo Raspberry



  • Hey,

    i am trying to cross compile QML Demo to the raspberry pi 3.
    I am using ubuntu 16.04 with Qt 5.8.
    when i run the demo version stocqt.qml i get the followed error: " module "QtQml.Models" version 2.0 is not installed"
    what am i doing wrong?
    thanks



  • i want to use also bluetooth... this is my ./config and Build options:

    :~/Downloads/qt-everywhere-opensource-src-5.8.0$ ./configure -release -opengl es2 -device linux-rasp-pi2-g++ -device-option CROSS_COMPILE=~/raspi/tools/arm-bcm2708/gcc-linaro-arm-linux-gnueabihf-raspbian-x64/bin/arm-linux-gnueabihf- -sysroot ~/raspi/sysroot -opensource -confirm-license -make libs -prefix /usr/local/qt5pi -extprefix ~/raspi/qt5pi -hostprefix ~/raspi/qt5 -qt-freetype -qt-xcb -fontconfig -glib -v

    Build options:
    Mode ................................... release
    Building shared libraries .............. yes
    Using C++ standard ..................... C++11
    Using gold linker ...................... yes
    Using new DTAGS ........................ yes
    Using precompiled headers .............. yes
    Using LTCG ............................. no
    Target compiler supports:
    NEON ................................. yes
    Build parts ............................ libs
    Qt modules and options:
    Qt Concurrent .......................... yes
    Qt D-Bus ............................... yes
    Qt D-Bus directly linked to libdbus .... no
    Qt Gui ................................. yes
    Qt Widgets ............................. yes
    Support enabled for:
    Accessibility .......................... yes
    Using pkg-config ....................... yes
    QML debugging .......................... yes
    udev ................................... no
    Using system zlib ...................... yes
    Qt Core:
    DoubleConversion ....................... yes
    Using system DoubleConversion ........ no
    GLib ................................... no
    iconv .................................. yes
    ICU .................................... no
    Logging backends:
    journald ............................. no
    syslog ............................... no
    Using system PCRE ...................... no
    Qt Network:
    getaddrinfo() .......................... yes
    getifaddrs() ........................... yes
    IPv6 ifname ............................ yes
    libproxy ............................... no
    OpenSSL ................................ no
    Qt directly linked to OpenSSL ........ no
    SCTP ................................... no
    Use system proxies ..................... yes
    Qt Sql:
    DB2 (IBM) .............................. no
    InterBase .............................. no
    MySql .................................. no
    OCI (Oracle) ........................... no
    ODBC ................................... no
    PostgreSQL ............................. no
    SQLite2 ................................ no
    SQLite ................................. yes
    Using system provided SQLite ......... no
    TDS (Sybase) ........................... no
    Qt Gui:
    FreeType ............................... yes
    Using system FreeType ................ no
    HarfBuzz ............................... yes
    Using system HarfBuzz ................ no
    Fontconfig ............................. no
    Image formats:
    GIF .................................. yes
    ICO .................................. yes
    JPEG ................................. yes
    Using system libjpeg ............... no
    PNG .................................. yes
    Using system libpng ................ yes
    OpenGL:
    EGL .................................. yes
    Desktop OpenGL ....................... no
    OpenGL ES 2.0 ........................ yes
    OpenGL ES 3.0 ........................ no
    OpenGL ES 3.1 ........................ no
    Session Management ..................... yes
    Features used by QPA backends:
    evdev .................................. yes
    libinput ............................... no
    mtdev .................................. no
    tslib .................................. no
    xkbcommon-evdev ........................ no
    QPA backends:
    DirectFB ............................... no
    EGLFS .................................. yes
    EGLFS details:
    EGLFS i.Mx6 .......................... no
    EGLFS i.Mx6 Wayland .................. no
    EGLFS EGLDevice ...................... no
    EGLFS GBM ............................ no
    EGLFS Mali ........................... no
    EGLFS Rasberry Pi .................... yes
    EGL on X11 ........................... no
    LinuxFB ................................ yes
    Mir client ............................. no
    Qt Widgets:
    GTK+ ................................... no
    Styles ................................. Fusion Windows
    Qt PrintSupport:
    CUPS ................................... no
    Qt SerialBus:
    Socket CAN ............................. yes
    Socket CAN FD .......................... yes
    QtXmlPatterns:
    XML schema support ..................... yes
    Qt QML:
    QML interpreter ........................ yes
    QML network support .................... yes
    Qt Quick:
    Direct3D 12 ............................ no
    AnimatedImage item ..................... yes
    Canvas item ............................ yes
    Support for Quick Designer ............. yes
    Flipable item .......................... yes
    GridView item .......................... yes
    ListView item .......................... yes
    Path support ........................... yes
    PathView item .......................... yes
    Positioner items ....................... yes
    ShaderEffect item ...................... yes
    Sprite item ............................ yes
    Qt Gamepad:
    SDL2 ................................... no
    Qt 3D:
    System Assimp .......................... no
    Qt Wayland Client ........................ no
    Qt Wayland Compositor .................... no
    Qt Bluetooth:
    BlueZ .................................. no
    BlueZ Low Energy ....................... no
    Linux Crypto API ....................... no
    Qt Multimedia:
    ALSA ................................... no
    GStreamer 1.0 .......................... no
    GStreamer 0.10 ......................... no
    Video for Linux ........................ yes
    OpenAL ................................. no
    PulseAudio ............................. no
    Resource Policy (libresourceqt5) ....... no
    DirectShow ............................. no
    Windows Media Foundation ............... no
    Qt Location:
    Gypsy GPS Daemon ....................... no
    WinRT Geolocation API .................. no
    Qt Sensors:
    sensorfw ............................... no
    Qt WebEngine:
    Proprietary Codecs ..................... no
    Spellchecker ........................... yes
    ALSA ................................... no
    PulseAudio ............................. no

    ERROR: Feature 'glib' was enabled, but the pre-condition 'libs.glib' failed.

    ERROR: Feature 'fontconfig' was enabled, but the pre-condition '!config.win32 && !config.darwin && features.system-freetype && libs.fontconfig' failed.


  • Moderators

    @ruphy Call configure with additional -v option and check what exactly is the problem: most probably missing dev packages for glib and fontconfig. Same for Bluetooth support: you will need to install needed libs and headers (dev packages).



  • thanks for answering.
    i tried some other precompiled stuff from http://www.qtrpi.com
    but then i got some other error:
    QML debugging is enabled. Only use this in a safe environment.
    Unable to query physical screen size, defaulting to 100 dpi.
    To override, set QT_QPA_EGLFS_PHYSICAL_WIDTH and QT_QPA_EGLFS_PHYSICAL_HEIGHT (in millimeters).
    QFontDatabase: Cannot find font directory /usr/local/qt5pi/lib/fonts.
    Note that Qt no longer ships fonts. Deploy some (from http://dejavu-fonts.org for example) or switch to fontconfig.

    now i am switched to qt 5.7.0 and i will try with qt-everywhere 5.7.0 and the following configure:
    ./configure -release -opengl es2 -device linux-rpi3-g++
    -device-option CROSS_COMPILE=~/raspi/tools/arm-bcm2708/gcc-linaro-arm-linux-gnueabihf-raspbian-x64/bin/arm-linux-gnueabihf-
    -sysroot /home/pi/raspi/sysroot -opensource -confirm-license
    -make libs -prefix /usr/local/qt5pi -extprefix /home/pi/raspi/qt5pi
    -hostprefix /home/pi/raspi/qt5

    let's see, if it works... i am very tired of trying :/
    is there any working tutorial with qt 5.7.0 and raspberry pi 3?


  • Moderators

    @ruphy So, you did not try what I suggested to find out what was missing?
    If you don't resolve such issues you will not be able to cross-compile anything.
    Tutorial: http://wiki.qt.io/Raspberry_Pi_Beginners_Guide



  • Problem solved... i took the precompiled stuff from qtrpi.com
    and the video tutorial shows that i had to set2 the variables in ~/.bashrc. e.g.:
    export QT_QPA_EGLFS_PHYSICAL_WIDTH=528
    export QT_QPA_EGLFS_PHYSICAL_HEIGHT=295
    export QT_QPA_FONTDIR=/usr/share/fonts/truetype

    after closing in terminal:
    source ~/.bashrc

    have fun.



  • @jsulm one last question:
    when i have qtcreator-5.7.0 than i have to take qt-everywhere 5.7.0 also?! can i use qt-everywhere5.7.1 or or qt-everywhere5.8?
    thanks


  • Moderators

    @ruphy There is no QtCreator 5.7. Latest QtCreator version is 4.2.2.
    QtCreator can handle any QtVersion and it can handle many different versions in parallel.


Log in to reply