Using QtCharts with Yocto Project



  • I use QT with yocto project. I create a custom image like this. My custom image file has the following lines for qtchart.

    qtcharts \
    qtcharts-dev \
    qtcharts-mkspecs \
    

    This image was created successfully and i have install my raspberry pi. I prepared QTCreator for cross development like this. I am using very well this system using qtcreator 5.7. When i installing qtcreator i choose qtcharts and i install qtcharts. I run qtcharts examples on my Ubuntu desktop. When i use kit for raspberry pi, i cant import QTCharts library. I installed qt-everywhere-opensource-src-5.7.0 qtcharts path for debug and release but thats not solved my problem. So I have reviewed the installation files and i saw the qtcharts library path is in

    /usr/lib/x86_64-linux-gnu/qt5/qml/
    

    i have coppy QTChart and some files about qtcharts in modules to

    /opt/poky/2.2/sysroots/cortexa7hf-neon-vfpv4-poky-linux-gnueabi/usr/lib/qt5/
    

    After this step i can import QTCharts. But when i use ChartView my project abruptly close and the only feedback is

    Process killed by signal
    How can i run qtcharts in my raspberry pi.

    Sorry for my bad English.



  • are you sure that headers/libraries you have copied have same version as the rest of the Qt on RPi?



  • I use qt source 5.7.0 for charts library. Rpi QT version is 5.7.0 too. But i dont know charts library versions.

    I also realized any other things for this error. When i try to import QTCharts library i wirte qt and after press ctrl + space. QTCreator doesnt show the QTCHarts library. This situation also seems trying to write version number. And i can write random version number like 9.5 for my QTChart import.


  • Moderators

    @Argprstest You copied QtCharts from your host (x86_64) Qt to the sysroot? That will not work. You need a QtCharts build for your target device (ARM).



  • I have remove all poky file in my opt path, after that i create image with "-c populate_sdk" command like this. Existed new .sh file in my sdk path. I have use that for create new poky path for cross development. The new file have a QTCHart library but that not solved my problem. When i use "ChartView", my program is still close by signal and QTCreator still cant show QTChart name when i use ctrl + space command.

    I have downgrade my qtcreator version to 3.5.1. I can see program close signal the 3.5.1 qtcreator. The signal is

    sh: line 1:  5653 Segmentation fault      DISPLAY=':0.0'
    


  • My problem caused a bug about QGuiApplication. I simply put QApplication instead of QGuiApplication and my problem was solve.



  • Hi all!
    I have the same issue, but i can not use QtCharts for BeagleBoneBlack., because of error

    1: error: Unknown module(s) in QT: charts
    

    i also copied all QTChart and some files about qtcharts from Qt_opensource\5.7\msvc2015_64 folder into arm-linux-gnueabihf\sysroot\usr\local\qt5 folder, but unsuccessfully, QtCharts still unavailable


  • Lifetime Qt Champion

    Hi,

    You have to cross-compile and install the module before you can use it.

    You can't use x86_64 .dlls to link against an ARM built library/application.



  • Hi, sure, i understand.
    when i cross-compiled qt for ARM - i did not see any options about QtCharts


  • Lifetime Qt Champion

    Compile it by hand.

    mkdir build_qtchart
    cd build_qtchart
    /path/to/your/cross-compiled-Qt/bin/qmake /path/to/your/QtChart_sources/
    make
    make install
    


  • /path/to/your/QtChart_sources/

    where it exsists?


  • Lifetime Qt Champion

    Wherever you downloaded Qt's sources.


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.