Disable bitcode for iOS project



  • When I build my project from Qt Creator, I see the following errors:

    ld: warning: -headerpad_max_install_names is ignored when used with -bitcode_bundle (Xcode setting ENABLE_BITCODE=YES)
    ld: -u and -bitcode_bundle (Xcode setting ENABLE_BITCODE=YES) cannot be used together
    

    When I run Qmake from the command line and load the Xcode project, I disable bitcode for the target. How can I do this from my qmake scripts so its disabled for QT Creator?

    Thanks!
    -Dave



  • Anyone? I'm just trying to build the device version of my app through Qt Creator, but some of my third-party libraries don't play nicely with bitcode, so I need to disable it. I can do it easily enough through Xcode, but I don't want to add that step in my workflow if I can avoid it.


  • Lifetime Qt Champion

    Hi,

    Not sure about it but try to add CONFIG -= bitcode to your .pro file

    Hope it helps



  • @SGaist unfortunately, that did not work.


  • Lifetime Qt Champion

    Then you can take a shot at fiddling with the bitcode.prf



  • This question is from a pretty long time ago, but I also ran into the issue (so I guess it's still relevant). There's also different solution that's not system wide. You can do the following:

    • Navigate to the "Projects" tab
    • Navigate to your Kit (e.g QT 5.9.1 for iOS) and Build variant (e.g. Debug)
    • Under "Build Steps" click on the "Add Build Step" button and add "xcodebuild"
    • Add "ENABLE_BITCODE=NO" without the quotation marks behind the command in the "Base arguments" textfield.
    • Disable the make step

    As an example:
    0_1509027285429_example.png


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.