[SOLVED] Yocto Project: Qt-GStreamer Development Package



  • Hi,
    I have compiled an meta-toolchain-qt5 SDK with Yocto Daisy Branch.
    I have a demo program that needed to use qt-gstreamer.
    in demo.pro
    There are these lines
    CONFIG += link_pkgconfig
    PKGCONFIG += Qt5GLib-2.0 Qt5GStreamer-1.0 Qt5GStreamerUi-1.0 Qt5GStreamerUtils-1.0 Qt5GStreamerQuick-1.0

    as I compile in Desktop, it said:
    error: Qt5GLib-2.0 development package not found

    I tried to download it from
    Qt Binding-GStreamer but is lacking a lot of lib. I cannot use the cmake also because of error finding qt components.

    How do I get the development package from the Yocto Distribution?

    I have already enable gstreamer in qtmultimedia.
    PKGCONFIG_append_pn_qtmultimedia = "gstreamer010 gstreamer"

    Thank you,


  • Lifetime Qt Champion

    Hi,

    You have to give cmake some hints to were it can find your Qt's cmake files. It won't find them automagically if you are not using the distribution's provided Qt.



  • @SGaist The current host I am using is ubuntu 14.04. I downloaded Qt5.5 creator from the Qt website.

    How do I do it? I am pretty new to cmake. This is the error log

    Performing C++ SOURCE FILE Test USE_OPENGLES failed with the following output:
    Change Dir: /home/hbulab/mountData/gstreamer/qt-gstreamer/CMakeFiles/CMakeTmp
    
    Run Build Command:/usr/bin/make "cmTryCompileExec135161727/fast"
    /usr/bin/make -f CMakeFiles/cmTryCompileExec135161727.dir/build.make CMakeFiles/cmTryCompileExec135161727.dir/build
    make[1]: Entering directory` /home/hbulab/mountData/gstreamer/qt-gstreamer/CMakeFiles/CMakeTmp'
    /usr/bin/cmake -E cmake_progress_report /home/hbulab/mountData/gstreamer/qt-gstreamer/CMakeFiles/CMakeTmp/CMakeFiles 1
    Building CXX object CMakeFiles/cmTryCompileExec135161727.dir/src.cxx.o
    /usr/bin/c++    -DUSE_OPENGLES -fPIE   -o CMakeFiles/cmTryCompileExec135161727.dir/src.cxx.o -c /home/hbulab/mountData/gstreamer/qt-gstreamer/CMakeFiles/CMakeTmp/src.cxx
    /home/hbulab/mountData/gstreamer/qt-gstreamer/CMakeFiles/CMakeTmp/src.cxx:2:27: fatal error: QtCore/QtGlobal: No such file or directory
     #include <QtCore/QtGlobal>
                               ^
    compilation terminated.
    make[1]: Leaving directory
    /home/hbulab/mountData/gstreamer/qt-gstreamer/CMakeFiles/CMakeTmp'
    make[1]: *** [CMakeFiles/cmTryCompileExec135161727.dir/src.cxx.o] Error 1
    make: *** [cmTryCompileExec135161727/fast] Error 2
    
    Source file was:
    
    #include <QtCore/QtGlobal>
    #if !defined(QT_OPENGL_ES)
    #error "No OpenGLES"
    #endif
    int main() {}

  • Lifetime Qt Champion

    cmake -DCMAKE_PREFIX_PATH=/pat/to/Qt5.5/lib should get you started.



  • This post is deleted!


  • Thank you, after installation a bunch of packages, I finally get the build.

    sudo apt-get install libgstreamer0.10-dev libgstreamer-plugins-base0.10-dev qt-sdk

    cmake -DCMAKE_PREFIX_PATH=~/Qt5.5.1/5.5/gcc_64/


  • Lifetime Qt Champion

    Since you are using Qt 5.5 I'd recommend using gstreamer 1.0



  • Just to add, if you are using the Qt for Device creation, some things in Qt Qmultimedia 5.5 still uses 0.10 although in documents they say you can use either 0.1 or 1.0


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.