run program in framebuffer but mouse is not showing up?



  • hey guys. I'm running a simple helloworld pushbutton program in frambuffer. Everything works fine except the mouse is not showing up. So is it suppose to be like this or should I set some environment variable to enable mouse?
    First time I tried to run it without doing anything, mouse not shown. 2nd time I exported QT_QPA_FB_HIDECURSOR=0, still no mouse.

    Thanks in advance for the help!


  • Lifetime Qt Champion

    Hi and welcome to devnet,

    What device are you running on ? What kind of mouse it ?

    In any case, if you are running embedded linux, here you have some more information about the setup of various aspects line input handling.

    Hope it helps



  • @SGaist hi, thanks for the reply. it's working on a raspberry pi (raspbian jessie), I'm using a normal wireless mouse and it works perfectly in xorg, so I suppose it should work well in framebuffer too, maybe my assumption is wrong.



  • @SGaist update: I solved the problem by setting the environment variable QT_QPA_GENERIC_PLUGINS=evdevmouse. it seems I went to the wrong page in first place, my qt is 5.3.2. so I need to enable the input device.


  • Lifetime Qt Champion

    You're welcome !

    Xorg handles several aspects including the input management. However, when using the frame buffer directly, it's your application's role to handle input and depending on your device, some hints are needed.

    Since you have it working now, please mark the thread as solved using the "Topic Tool" button so that other forum users may know a solution has been found :)

    Also, while browsing the forum, consider up-voting answers that helped you, it will make them easier to find for other users :)


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.