[Solved] Deploy project on real device



  • Hi Folks,

    just for information: I solved this problem. It caused by the subdir organization of the project. As I discover, only the .exe was packed into the .apk and the other dll-s were missing. I don't know, how should I instruct the Qt to package other dll-s into the .apk as well so I restructure the project.

    Regards,
    Norbert

    Hi Folks,

    first of all I would like you to getting into context: I'm using Qt about 4 years ago on desktop and I have approximately 5 C++ experience.
    So, I have a "subdir" project. The development environment consist of the followings:

    • project target: desktop and armeabi7a
    • device: SoftwinerEvb tablet with API version 15
    • Installed APIs on the development PC: 15 and 23

    If I select the API15 as build target, I get the following error message:
    [aapt] <project/path>-Android_for_armeabi_v7a_GCC_4_9_Qt_5_5_0-Debug/android-build/bin/AndroidManifest.xml:4: error: Error: String types not allowed (at 'configChanges' with value 'orientation|uiMode|screenLayout|screenSize|smallestScreenSize|layoutDirection|locale|fontScale|keyboard|keyboardHidden|navigation').
    [aapt]

    BUILD FAILED
    <path>/android-sdk-linux/tools/ant/build.xml:649: The following error occurred while executing this line:
    <path>/android-sdk-linux/tools/ant/build.xml:694: null returned: 1

    Total time: 3 seconds
    Building the android package failed!
    -- For more information, run this command with --verbose.
    18:31:53: The process "<path>/Qt/5.5/android_armv7/bin/androiddeployqt" exited with code 14.
    Error while building/deploying project engineering (kit: Android for armeabi-v7a (GCC 4.9, Qt 5.5.0))
    When executing step "Build Android APK"

    I googled for the solution and I found that I should increase the API version. I switched to 23. The compilation has been successfully, but I cannot download to the device under Ubuntu, but I can under Windows.
    If I download the application (again: the device has version 15 I had to use 23), the application crash immediately: "Unfortunately, <project> has stopped".

    Can anybody help me? I don't know how should I start to fix the issue. I don't know too much about the android development, etc.

    p.s.: If I tried out my project on emulator with API version 15, everything went fine.

    Regards,
    Norbert



  • Hi Folks,

    as I see, there is no answer for my question. In other worlds, how should I start to debug the root cause of my applications crash?
    E.g.: API version number, Qt versions, CPU architecture, start the application from debugger on the device, etc.

    Regards,
    Norbert


  • Lifetime Qt Champion

    Hi,

    One thing you can do is to join the #necessitas IRC channel, you'll find there the developers/maintainers of the Android port of Qt


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.