iOS - How to connect to PostgreSQL?



  • Hello Forum,

    I have a problem with connect to PostgreSQL. I use Qt 5.5.
    I build a library of PostgreSQL, but I can not connect from under iphonesimulator
    How to connect to PostgreSQL from under iOS ?
    Can anybody help me with this problem?

    Sorry for my bad english.



  • Hi and welcome to devnet,

    have you deployed the PostgreSQL plugin on the simulator??



  • Hi,

    I pointed out in .pro file

    ios {
    QTPLUGIN += qsqlpsql
    }

    and in soource code

    #include <QtCore/QtPlugin>
    Q_IMPORT_PLUGIN(qsqlpsql)

    but when compile the project generates an error:
    "qt_static_plugin_qsqlpsql()", referenced from:
    StaticqsqlpsqlPluginInstance::StaticqsqlpsqlPluginInstance()
    ld: symbol(s) not found for architecture i386



  • @Thrash said:

    symbol(s) not found for architecture i386

    are building for iOS of for x86??



  • @mcosta said:

    are building for iOS of for x86??

    Yes


  • Lifetime Qt Champion

    Hi,

    Did you build the PostgreSQL plugin ?



  • Hi,

    I build PostgreSQL plugin for IOS (iphonesimulator)
    When compiling errors appear:
    clang: error: invalid architecture ‘arm’ for deployment target ‘mios-simulator-version-min=5.1.1’
    clang: error: invalid architecture ‘aarch64’ for deployment target ‘mios-simulator-version-min=5.1.1’

    How do I solve it? Thank you!


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.