Qt 5.2.1 QQuickFrameBufferObject: multisampling not working



  • Hello,

    I'm using a QQuickFramebufferObject and Renderer two draw custom graphics with OpenGL ES 2.0. I'm not able to switch to a newer Version of Qt!

    I have implemented my class based on the this Qt Blog article.

    My problem is, that I want to enable multisampling, but it isn't working. In the article they say multisampling can be enabled by setting the sample counter in QOpenGLFramebufferObjectFormat greater than zero:

    Finally, it is worth noting that QQuickFramebufferObject is also prepared to handle multisampling and screen changes.
    Whenever the QOpenGLFramebufferObject returned from createFramebufferObject() has multisampling enabled (the QOpenGLFramebufferObjectFormat has a sample count greater than 0 and multisampled framebuffers are supported by the OpenGL implementation in use), the samples will be resolved with a glBlitFramebuffer call into a non-multisampled FBO after each invocation of render(). This is done transparently to the applications so they do not have to worry about it."

    Finally I know that multisampling is working, because I also draw some stuff with the QQuickPainter and this graphic is multisampled.
    I have the same result if I run my programm for the embedded linux target or my linux working machine.

    Thanks for your help in advance!

    Best regards
    Heiko



  • Hello,

    no ideas?
    Do you need a minimal project from me?

    Best regards
    Heiko


  • Lifetime Qt Champion

    Hi,

    Yes, a minimal compilable project would be good. Unless people hit the same problem as you, recreating the same setup is not easy. You should also provide your Qt version and OS



Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.