[SOLVED] Unable to deploy freshly created project to android



  • Hi,

    I am using Qt 5.5. and qtcreator 3.4.2. I am on Windows 8.1.
    When I create one of the android examples from the welcome screen (in my case the Anchor Layout example) it works. I can deploy and test it on android.

    But when I create a new project and try to deploy it to android, the process stops at step 3 of 5 and I get the error:

    [install target] Error 1
    

    In the "build-problems" tab.

    Now on the "compilation" tab it says:

    16:53:34: Führe Schritte für Projekt qtwidgetstest aus...
    16:53:34: Unveränderte Konfiguration, qmake-Schritt wird übersprungen.
    16:53:34: Starte "C:\Qt\Tools\mingw492_32\bin\mingw32-make.exe"
    C:\Qt\5.5\android_armv7\bin\qmake.exe -spec android-g++ "CONFIG+=debug" -o Makefile ..\qtwidgetstest\qtwidgetstest.pro
    Das System kann den angegebenen Pfad nicht finden.
    mingw32-make: Nothing to be done for 'first'.
    16:53:35: Der Prozess "C:\Qt\Tools\mingw492_32\bin\mingw32-make.exe" wurde normal beendet.
    16:53:35: Starte "C:\Qt\Tools\mingw492_32\bin\mingw32-make.exe" INSTALL_ROOT="C:\Users\Mira\Documents\PROMPT\qt tests\build-qtwidgetstest-Android_f_r_armeabi_v7a_GCC_4_9_Qt_5_5_0-Debug\android-build" install
    Das System kann den angegebenen Pfad nicht finden.
    Das System kann den angegebenen Pfad nicht finden.
    
    makefile:1664: recipe for target 'install_target' failed
    
    mingw32-make: *** [install_target] Error 1
    16:53:36: Der Prozess "C:\Qt\Tools\mingw492_32\bin\mingw32-make.exe" wurde mit dem Rückgabewert 2 beendet.
    Fehler beim Erstellen/Deployment des Projekts qtwidgetstest (Kit: Android für armeabi-v7a (GCC 4.9, Qt 5.5.0))
    Bei der Ausführung von Schritt "Anwendungsdaten kopieren"
    
    16:53:36: Verstrichene Zeit: 00:02.
    

    It tells me that it can not find some path, but it does not tell which path is the problem.

    Thanks for any help,
    Nathan


  • Lifetime Qt Champion

    Hi,

    The first thing I would do is remove the space you have in your path. e.g. use "qt_tests" rather than "qt test". Spaces in paths are often a problem on Windows



  • That was it! Thanks!


  • Lifetime Qt Champion

    You're welcome !

    Since you have it working now, please update the thread title prepending [solved] so other forum users may know a solution has been found :)

    Also, consider up voting answer(s) you find useful while browsing threads, it will help other users to find them more easily :)


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.