Unable to build QT 5.4 for iOS from source



  • I'm unable to build Qt 5.4.2 for iOS nor iphonesimulator.

    Having errors during configure part, then having fatal errors while performing make step.

    New to building from source, my configure command is
    /configure -top-level -xplatform macx-ios-clang -sdk iphonesimulator -nomake tests -debug-and-release -confirm-license -v

    then getting errors and warnings, like

    clang: warning: treating 'c' input as 'c++' when in C++ mode, this behavior is deprecated
    Symbol visibility control enabled.
    clang: error: invalid linker name in argument '-fuse-ld=gold'
    /Applications/Xcode.app/Contents/Developer/Toolchains/XcodeDefault.xctoolchain/usr/bin/clang++ -o libtest.so -shared -Wl,-Bsymbolic-functions -fPIC bsymbolic_functions.c
    clang: warning: treating 'c' input as 'c++' when in C++ mode, this behavior is deprecated
    ld: unknown option: -Bsymbolic-functions
    clang: error: linker command failed with exit code 1 (use -v to see invocation)
    Symbolic function binding disabled.

    then

    Project ERROR: mtdev development package not found
    mtdev disabled.

    libjpeg.cpp:37:10: fatal error: 'jpeglib.h' file not found
    #include <jpeglib.h>
    ^
    1 error generated.
    make: *** [libjpeg.o] Error 1
    libjpeg disabled.

    and many more similar to this one

    As i said I'm new to building from source. I've checked my XCode version and sdk versions, everything should be ok, but regarding those errors I assume I'm having some troubles with linking or something like it.

    Thank you for any help ;)


  • Lifetime Qt Champion

    Hi,

    Do you have the same error if you use the line provided in the Building from source iOS ?



  • @SGaist I think is was the first thing i tried, but it didn't work, so i tried some different configure commands i found, like the one above. I can try it again and tell you.



  • @SGaist

    I tried again to build it with configure commant with that guide ./configure -xplatform macx-ios-clang -release and got the same error.

    Without -nomake argument it starts to make after same errors thrown, and while making it throws fatal errors like Unsupported architecture, then a lot of unknown type errors in types.h and everything ends in a few seconds by sentence too many errors emitted, stopping now. Then it says STL disabled.
    STL functionality check failed! Cannot build Qt with this STL library.

    Here is where i posted a whole report : http://pastebin.com/jSPp14Qz


  • Lifetime Qt Champion

    What version of Xcode are you using ?



  • @SGaist I'll let you know as i get to my mac, but i hope i'm using the latest one.



  • @SGaist So I have the latest XCode, but errors are still the same. I really don't understanad where the problem is. When it starts the making step, it emmits an Unsupported architecture error. The full list of errors during config and make steps is 2 posts above. I'm starting to be desperate ..



  • @phobos8
    Hi
    I've got the exact same problem on my Mac with OSX Yosemite and XCode 6.1.
    I cloned the source, checked out to version 5.4.2 and tried to configure but I get the same errors as you.

    Do you have a solution yet?

    thanks in advance,
    best regards
    Manfred



  • Oh well, I had a typo in my config path, sorry !
    Configure and make work well now!

    cheers
    Manfred


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.