Error configuring Qt on VirtualBox running Ubuntu. Target BeagleBone Black



  • Hi to everyone,

    I am currently trying to build Qt Creator on my BeagleBone Black running Debian to deploy a simple Qt Application. I have a Windows 7, 64 bit host machine and a Ubuntu 14 LTS as Guest running on VirtualBox.

    I have followed this tutorial: http://armsdr.blogspot.de/2014/01/bare-metal-qt-52-on-beaglebone-black_10.html

    However, when I tried to configure Qt on my Ubuntu machine with the following command:
    "../qt-everywhere-opensource-src-5.2.0/configure \
    -v \
    -opensource \
    -confirm-license \
    -prefix /usr/local/qt-5.2 \
    -no-largefile \
    -no-accessibility \
    -qt-zlib \
    -no-gif \
    -qt-libpng \
    -qt-libjpeg \
    -no-nis \
    -no-cups \
    -xplatform linux-linaro-gnueabihf-g++ \
    -device linux-beaglebone-g++ \
    -device-option CROSS_COMPILE=/usr/local/linaro/bin/arm-linux-gnueabihf-"

    I get a huge error, from which I believe the most important parts are: /usr/local/linaro/bin/arm/arm-linux-gnueabihf-g++: not found Precompiled-headers support disabled
    Also: Symbol visibility control disabled AND Symbolic function binding disabled

    At the very end while creating qmake I get:

    "make: g++: Command not found"
    "make: [project.o] Error 127"

    I must mention that due to a lack of internet on my virtualBox, I did NOT run the following commands: sudo apt-get install lsb and sudo apt-get install ia32-libs. Do you guys think that that could be the reason for the error? Apart from that everything is practically the same.
    Any kind of help is greatly appreciated!



  • Hi. Despite targeting an arm machine, all Qt tools (qmake,moc,etc) will be built as native applications for the host platform (Ubuntu, in your case). That's why you need both g++ and arm-linux-gnueabihf-g++.

    If you're developing on Windows, I would suggest you to compile it using Windows. So you can integrate your build to Qt Creator and then easily compile and deploy your application. I have done it for a Cubieboard2 I have. You can setup an environment using MinGW, MSYS and the Linaro toolchain. It's a little bit painful, but once everything is settled, the hard work will pay off.



  • @Leonardo
    Hello and thank you for replying,

    I have found out that I don't have "g++" installed on my virtual machine and due to the fact that I don't have internet connection, I can't get the installation with "apt-get" (at least not until now). However I do think that it would be better if I could cross-compile directly from Windows.
    Do you know of any link with a tutorial on how to do it? Honestly, I am pretty new at this and sometimes I have no idea of what I am doing, so without a tutorial to follow it would be pretty impossible for me.

    I found this tutorial http://c2143.blogspot.de/?view=classic but I can't seem to download this "Jom" thing. Apparently because of a firewall since I am using the network of my office. Would you recommend me another one?



  • Hi. I don't know any tutorial. I'm sorry. There are really few resources about cross compilation on Windows. It took me one week to get it all working, but that link you posted seems like a good starting point. I don't know Qt 4, but I can tell you don't need Jom for Qt 5, whether you're using Visual Studio or MinGW. You can skip it.


  • Lifetime Qt Champion

    Hi,

    Jom is provided with Qt Creator.



  • Hi Leonardo and SGaist,

    again thanks for answering and sorry for taking so long to get back at you but I was kinda busy.

    Just now I retook this problem of deploying Qt applications on my BeagleBone Black trough Windows. I stopped following the above tutorial because it uses a "Qt 4.8 source git checkout from gitorious" and apart from now knowing what that is, I couldn't download it. I saw a video of a guy that deploys applications setting up a new Kit in Qt creator. In "Tools->Options..." Then he added the corresponding GCC Compiler, Debugger and the qmake file that were in his toolchain.

    Since I am using a BeagleBone Black running Debian, I downloaded this toolchain: "gcc-linaro-arm-linux-gnueabihf-4.8-2013.06_win32.zip" from the website https://releases.linaro.org/13.06/components/toolchain/binaries
    My problem is that in this toolchain I cannot find the file or executable that the guy from the video uses in "Qt versions". He uses a "qmake2" that is in the "bin" file of his toolchain, but in this toolchain that I use I cannot find such a file. Could you tell me if this is the right way to deploy Qt applications on BeagleBone Black and if I am using the right toolchain and possibly point me in the right direction? Thanks in advance for any kind of help.



  • Hi. I don't know the video you are referring to, but there's no qmake2 in the toolchain. That's right. You know, I've been willing to write an article on Qt's wiki about cross-compilation on Windows, but it's been some time since I've been through this process, so I don't remember all the details. I think many Windows developers would benefit from it. Now that you're going through the same path, would you consider helping me writing this article? I could give you the main steps and you would fill in the details. What do you think about it?



  • @Leonardo
    No problem by me. I must tell you though, I am no developer nor am I an expert in any sense of the word. But I had already thought that if I can make this work soon, I would do a video or a page with the steps on how to do it. Anyway, if it works for me I wouldn't have any problem in writing something down to help other people with it. But first I have to make it work for me and know what am I doing I believe.



  • I just wanted to let you guys know that I will be making a new Topic since I believe that the title of the actual one is a little misleading.


  • Lifetime Qt Champion

    You can also just rephrase the title if the topic is still the same



  • Hello all,

    The idea of writing some article with steps on how to build application in Qt for ARM linux is great.
    It is very much required.
    I already have working target with Ubuntu as development, but I need to give the capabilty to build a Qt application from windows. I got into trouble with it.

    Regards,
    Ran


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.