[solved] Cannot read from input file: android-lib*.so-deployment-settings.json



  • I try to compile qt demos for Android platform by console command:
    @qmake
    make install INSTALL_ROOT=android-build
    ../../qt/5.2.1/android_x86/bin/androiddeployqt --output android-build@
    And get output:
    @Cannot read from input file: android-lib{app_name}.so-deployment-settings.json@

    GUI compilation runs successfully

    Install packages:
    @sudo apt-get install openjdk-7-jdk@
    !http://www.7image.ru/pics/0214/424321315.png(qt gui prefs)!

    I was researching this problem and tryed fix it. Ineffectually
    I need help)



  • Fixed! BUILD SUCCESSFUL
    This is Error: qmake was linked gcc\bin\qmake
    Next Enviroment Variables is usefully for me (this is true for android x86 builds, for others you need setting other qt-tools path).

    #For Android SDK & NDK
    export ANDROID_NDK_ROOT=/media/for-android/android-ndk-r9c
    export ANDROID_SDK_ROOT=/media/for-android/android-sdk-linux

    #For Compile by QT tools
    export PATH=/media/Qt5.2.1/5.2.1/android_x86/bin/:/media/Qt5.2.1/5.2.1/android_x86/bin:$PATH

    #For Java JDK set
    export JAVA_HOME=/usr/lib/jvm/java-1.7.0-openjdk-amd64

    If necessary:

    #For Ant
    ANT_HOME=/usr/bin/ant



  • How I can to close this topic..?



  • Just edit the title and add [Solved] in the beginning. I don't know if you can close topics.


  • Lifetime Qt Champion

    Hi,

    Currently the only way to "close" is to prepend [solved] to your thread title

    Happy coding !


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.