Important: Please read the Qt Code of Conduct - https://forum.qt.io/topic/113070/qt-code-of-conduct

Could not resolve all artifacts for configuration ':classpath'



  • Hello,
    I am using Ubuntu 20, Qt 5.15.1 and QtCreator provided with it.
    OpenJDK 9.0.4 | NDK 21.1.6352462 | SDK 3.0

    I am trying to launch Android Example Mapviewer but at the end of the build i get:

    WARNING: An illegal reflective access operation has occurred
    WARNING: Illegal reflective access by org.codehaus.groovy.vmplugin.v7.Java7$1 (file:/home/krzysztof/.gradle/wrapper/dists/gradle-5.6.4-bin/bxirm19lnfz6nurbatndyydux/gradle-5.6.4/lib/groovy-all-1.3-2.5.4.jar) to constructor java.lang.invoke.MethodHandles$Lookup(java.lang.Class,int)
    WARNING: Please consider reporting this to the maintainers of org.codehaus.groovy.vmplugin.v7.Java7$1
    WARNING: Use --illegal-access=warn to enable warnings of further illegal reflective access operations
    WARNING: All illegal access operations will be denied in a future release
    
    FAILURE: Build failed with an exception.
    
    * What went wrong:
    A problem occurred configuring root project 'android-build'.
    > Could not resolve all artifacts for configuration ':classpath'.
       > Could not resolve com.android.tools.build:gradle:3.6.0.
         Required by:
             project :
          > Could not resolve com.android.tools.build:gradle:3.6.0.
             > Could not get resource 'https://dl.google.com/dl/android/maven2/com/android/tools/build/gradle/3.6.0/gradle-3.6.0.pom'.
                > Could not GET 'https://dl.google.com/dl/android/maven2/com/android/tools/build/gradle/3.6.0/gradle-3.6.0.pom'.
                   > sun.security.validator.ValidatorException: PKIX path building failed: sun.security.provider.certpath.SunCertPathBuilderException: unable to find valid certification path to requested target
          > Could not resolve com.android.tools.build:gradle:3.6.0.
             > Could not get resource 'https://jcenter.bintray.com/com/android/tools/build/gradle/3.6.0/gradle-3.6.0.pom'.
                > Could not GET 'https://repo.jfrog.org/artifactory/libs-release-bintray/com/android/tools/build/gradle/3.6.0/gradle-3.6.0.pom?referrer'.
                   > sun.security.validator.ValidatorException: PKIX path building failed: sun.security.provider.certpath.SunCertPathBuilderException: unable to find valid certification path to requested target
    

    What can I do about it?



  • @Kyeiv said in Could not resolve all artifacts for configuration ':classpath':

    OpenJDK 9.0.4

    You need to use Java 8, see here.

    Versions higher than 8 might cause issues for the Android SDK command-line tools.



  • @Kyeiv said in Could not resolve all artifacts for configuration ':classpath':

    OpenJDK 9.0.4

    You need to use Java 8, see here.

    Versions higher than 8 might cause issues for the Android SDK command-line tools.