Important: Please read the Qt Code of Conduct - https://forum.qt.io/topic/113070/qt-code-of-conduct

Cannot read from input file



  • I'm trying to use androiddeployqt to deploy a Qt application to an Android device. I've followed the required steps before running androiddeployqt, and when I run the make install INSTALL_ROOT=$BUILD_TARGET command, this is the output:

    /bin/sh: 1: androiddeployqt: not found
    /bin/sh: 1: androiddeployqt: not found
    Makefile:555: recipe for target 'install_package' failed
    
    

    Then when I build and run androiddeployqt on my project, this is what I'm getting:

    Cannot read from input file: android-libandroid.so-deployment-settings.json
    Cannot read from input file: android-libandroid.so-deployment-settings.json
    make: *** [install_package] Error 2
    10:09:35: The process "/home/<user>/Android/Sdk/ndk-bundle/prebuilt/linux-x86_64/bin/make" exited with code 2.
    Error while building/deploying project <project name> (kit: Android for armeabi-v7a (Clang Qt 5.12.3 for Android ARMv7))
    When executing step "Copy application data"
    

    The 'android' before the .so is the name of my build directory.
    I'm pretty sure I followed the documentation to a T, so I think I'm missing something obvious. Can someone point me in the right direction? Thanks.


  • Lifetime Qt Champion

    Hi,

    What version of the SDK/NDK are you using ?
    How did you install them ?



  • This post is deleted!


  • @SGaist I'm using SDK 26.1.1 and NDK 19.2.5345600, but I solved the problem. I was able to find the JSON file generated by qmake and included it in the input flag for androiddeployqt. The app built successfully and deploys to the emulator.


Log in to reply