Important: Please read the Qt Code of Conduct - https://forum.qt.io/topic/113070/qt-code-of-conduct

RPI cross-compilation errors : lGLESv2,cannot find id and xcb



  • hello,
    Previously I had followed this link https://wiki.qt.io/RaspberryPi2EGLFS and succefully intalled Qt on UBUNTU 16 to cross compile on RPI 3B+.
    now i wanted to do the same with another RPI.
    I follwed the same link as above and did steps only concerning RPI and not PC obviously because it already had QT installed.
    after solving many issues i am stuck on these two things During Cross-Compiling program.
    :-1: error: cannot find -lGLESv2
    :-1: error: collect2: error: ld returned 1 exit status

    i installed messa-dev libs but nothing seems to work
    and

    when run QT make file of program ( make file copied from PC)it gives error like
    cannot find or load the Qt platform plugin "xcb".
    Please help,
    regards.


  • Lifetime Qt Champion

    Hi,

    Based on this answer the library name have changed in Stretch.



  • @SGaist
    so problem is in qt creator installed on ubuntu pc?
    which makefile should i edit?


  • Lifetime Qt Champion

    It's not a problem of Qt Creator. The mkspec used for the RPI3 is still valid unless your sysroot comes from a Debian Stretch were they have changed the library name.

    You need to modify the mkspec under devices that matches the Rpi3