It's not a problem of Qt Creator. The mkspec used for the RPI3 is still valid unless your sysroot comes from a Debian Stretch were they have changed the library name. You need to modify the mkspec under devices that matches the Rpi3