Important: Please read the Qt Code of Conduct - https://forum.qt.io/topic/113070/qt-code-of-conduct

Can not deploy app from qtcreator, error code 1073741515



  • Hi guys. I have installed android studio(Platform is Windows 7), Android SDK API 28 and Android NDK, set all configuration so I don't get any error, everything looks fine. I chose Quick application template. Architecture is x86. Qt version is latest. Build option is Debug(But I tried Release mode as well). But when I try to run from my qt creator it starts emulator(which I created under android studio, under AVD tool) I get an error:

    :-1: error: [qrc_qml.cpp] Error -1073741515

    and in compile output:

    Deploying to
    18:53:29: Running steps for project test1...
    18:53:29: Configuration unchanged, skipping qmake step.
    18:53:29: Starting: "C:\Users\me\AppData\Local\Android\Sdk\ndk-bundle\prebuilt\windows-x86_64\bin\make.exe" -j8
    E:\Qt\5.13.0\android_x86\bin\rcc.exe -name qml ..\test1\qml.qrc -o qrc_qml.cpp
    make: *** [qrc_qml.cpp] Error -1073741515
    18:53:30: The process "C:\Users\me\AppData\Local\Android\Sdk\ndk-bundle\prebuilt\windows-x86_64\bin\make.exe" exited with code 2.
    Error while building/deploying project test1 (kit: Android for x86 (Clang Qt 5.13.0 for Android x86))
    When executing step "Make"
    18:53:30: Elapsed time: 00:01.

    So qt creator can't deploy apk on the virtual device. Can someone give me handy advice? If you need more info I can provide.
    Thanks in advance



  • @Giorgi

    What is the Qt version you are using?
    What is the Android device architecture you are trying to deploy to?
    When you are pressing Ctrl+r you should see a dialog for selecting the device for deploying. Is your device listed?
    What kind of device are you using?



    1. QT version is 5.13.0 alpha
    2. Andrroid device is emulated Nexus 6P - API 28(but i tried different emulated devices). Processor architecture is x86
    3. Yes when i run (press(Ctrl + r) I see devices list and choose one of them(e.g Nexus 6P - API 28) device starts but in qt issues console i have this error :-1: error: [qrc_qml.cpp] Error -1073741515
    4. device is emulated android phone. e.g Nexus 6P


  • @Giorgi

    Do you have a specific reason to use an alpha version of Qt?
    Personally I would for a released version. Alpha version are typically not even close to a release like release candidates. Therefore, you may encounter more problems.

    Do you have experience with virtual device for testing with Qt creator and a previous released version of Qt libs?



  • Ok I tried stable 5.12.1 version and now it works fine. Thanks for you answers. How can I set solved status to this post?



  • This post is deleted!

  • Lifetime Qt Champion

    @Giorgi it's in the Topic Tools button below your first post. For now, I marked as SOLVED for you ;)



  • Ok. Thanks


Log in to reply