Qt Scene graph not using the OpenGL for rendering in Raspberry Pi 3B+



  • I was trying to analyze the performance of Qt Quick applications in Raspberry Pi 3B+. To understand the renderer the Qt scenegraph is using by setting the QSG_INFO =1. It was logging the following statement when the application starts:

    qt.scenegraph.general: Loading backend software

    Does it mean the Qt scene graph is not using the open gl render? If it is not using open gl rendering, how can I try to enable the open gl rendering in Raspberry pi 3B+. I have enabled the GL driver in Raspberry Pi 3B+ using the GL driver option in the raspi-config option.
    I have then tried including the QQuickWindow::setSceneGraphBackend(QSGRendererInterface::OpenGL); in main function. But the debug statement remained same.

    I am not able to add the Qt Graphical effects and particle system in the application.(They are not at least visible in the application)


  • Moderators

    You need to use the EGLFS plugin, it has best performance on RPi. To do that, you'll probably need to compile Qt yourself. Guides:


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.