Important: Please read the Qt Code of Conduct - https://forum.qt.io/topic/113070/qt-code-of-conduct

Qt Creator Form View problem



  • Using Qt Creator 4.6.2 on Linux, Qt version is 5.11.1

    Problem is that for some reason when I try to edit form all I see is a grid instead of a form.
    Used to work fine, I don't know if it's some setting, maybe I pressed something wrong, I'm not sure what happened.
    Any help appreciated.

    0_1537719572336_20180923-181753.png


  • Qt Champions 2019

    @kajzer Your QtCreator isn't in designer mode. The designer mode is disabled for some reason. Check whether designer plug-in is activated. Go to "Help/Plugins..." and see there.



  • @jsulm It's enabled.
    I deleted QtProject folder in .config directory and tried with new config to see what will happen, and now when I double click on .ui file I get "Image format not supported", it doesn't even display grid, it goes back to .cpp editor.
    That made me think that maybe some USE flag isn't enabled, I'm using Gentoo linux, so each package is compiled from source, maybe some feature wasn't compiled, I'm providing screenshot of enabled features (they are in red color) , maybe the problem is there ?
    Again, it used to work fine for a long time, it started to behave like this maybe two months ago, didn't change any of options or something like that.

    0_1537780698044_20180924-110744.png

    0_1537780709083_20180924-111112.png

    0_1537780723253_20180924-111155.png


  • Qt Champions 2019

    @kajzer What happens if you right click on the UI file and select "Open With/Qt Designer"?



  • @jsulm It opens with a grid.
    However, I've tried to open it via terminal and now I see error messages when I try to open .ui file

    static Core::EditorManager::EditorFactoryList Core::Internal::EditorManagerPrivate::findFactories(Core::Id, const QString&) unable to determine mime type of /home/kajzer/QT Creator Projects/Testing2/mainwindow.ui/. Falling back to text/plain
    qt.svg: Cannot read file '/home/kajzer/QT Creator Projects/Testing2/mainwindow.ui', because:  (line 2)
    

    Don't know why it sees .ui files as svg, maybe that's normal and how this works, I'll try to investigate more.


  • Qt Champions 2019

    @kajzer This is strange. Maybe you can try to change the mime type for ui in your desktop environment?



  • @jsulm mime type for ui files is "application/x-designer"
    Default application that opens it is "Qt Creator (org.qt-project.qtcreator)"

    I can change the mime type but to which one ?


  • Qt Champions 2019

    @kajzer Looks correct, I really have no idea what is going on. You could try to reinstall QtCreator.



  • @jsulm Yeah really weird, apart from that everything else is fine, luckily I don't use much Designer but still....
    Thanks for your interest in this, I will report the solution if I find it.



  • Found the exact problem reported here :
    https://bugs.archlinux.org/task/58312

    If I understand the solution correctly I need to rebuild QtCreator with Qt 5.11
    Which I'm going to do and mark this as solved if that's the case.



  • Rebuilding it solved the problem indeed.


Log in to reply