Important: Please read the Qt Code of Conduct - https://forum.qt.io/topic/113070/qt-code-of-conduct

Setting up a raspberry for remote development for running an application



  • Hello to all,
    I worked with QT-Creator on my UBUNTU PC very well.
    But now I crashed my LCD screen an I do not get a new identical one.
    I bought a new on and now I try to run my application on a new installed Raspberry.
    Now my real problem:
    What must I setup on the Raspberry to run and debug the application without any errors.
    Now I see the listening on port 10000
    Remote debugging from host 192.168.180.26
    Process /home/pi/Teleskop created; pid = 2187
    Here I got more information:
    When I run it on a Terminal
    pi@raspberrypi:~ $ ./TestL-Kuman-CD
    ./TestL-Kuman-CD: /usr/lib/arm-linux-gnueabihf/libQt5Core.so.5: no version information available (required by ./TestL-Kuman-CD)
    ./TestL-Kuman-CD: /usr/lib/arm-linux-gnueabihf/libQt5Widgets.so.5: no version information available (required by ./TestL-Kuman-CD)
    QXcbConnection: Could not connect to display
    Aborted

    Thats it.
    I think i must configure the raspberry.
    Please can you give me a hint what to do
    Thanks
    Kirt



  • Hello again,
    I found out that I have possibly a wrong version of QT. It is
    Qt Creator 4.5.0
    Based on Qt 5.10.0 (GCC 5.3.1 20160406 (Red Hat 5.3.1-6), 64 bit)

    Built on Dec 4 2017 04:11:21

    From revision fcea6ceba6
    Is this correct?
    Thanks
    Kurt


  • Lifetime Qt Champion

    Hi,

    No, the Qt version used to build Qt Creator has nothing to do with the version you are using to build your application.

    Is your current RPi configured the same way as the other one ?



  • Hi,
    thanks for your answer.
    I think I have to rebuild the rpi configuration.
    But is it possible to make it on a windows PC? And how can I setup the qt version? I can not find a qmake*.exe.
    Kurt


  • Lifetime Qt Champion

    It should be possible to do on a Windows machine however it's way harder. You should then consider using a virtual machine with Linux running on it.

    @K-Str said in Setting up a raspberry for remote development for running an application:

    And how can I setup the qt version?

    What do you mean ?



  • Hello SGaist,
    thanks for your answer!
    I have a basic question:
    what about
    Qt Creator 4.7.0
    Based on Qt 5.11.1 (MSVC 2015, 32 bit)

    Erstellt am Jul 17 2018 04:27:33

    Revision dedbb40f57
    It seems it doeas not support a raspberry device. It says:
    "***The compiler RPI C++... cannot create a code for the Qt-Version "Qt5.11.1 ...***"
    See attached picture!
    0_1536994006865_QT Kits.JPG
    What does it mean Qt-Version 5.1.11.1 (Raspberry) ***(x86-windows-mysys-pe-32bit)***?


  • Lifetime Qt Champion

    Did you cross-compile Qt already ?



  • Hi SGaist,
    yes and it worked fine.
    But now I got a new LCD display and I need to change something because the graphic driver on the Raspberry have changed.
    I got a new image for the Raspberry.
    I need to know how to change the tool-chain on a host and raspberry.
    Kurt


  • Lifetime Qt Champion

    What exactly did change ?

    A graphic driver change doesn't imply a full toolchain change more likely a re-build of the Qt backend used for your application.



  • Hi SGaist,
    I got a new LCD screen. The old one used a HDMI interface and the new one uses SPI ports.
    What does it mean "re-build of the Qt backend"? Where can I find a description for such a work?



  • Due to the nature of the brcm chip on the raspberry one can not use the eglfs platform plugin with spi displays. You have to use linuxfb or run something to mirrow the hdmi out to the framebuffer of your spi display. Didn´t we talked about this some time ago?



  • Hello sneubert,
    thanks for your hint!
    Yes we talked about this and I didn'remember.
    But it seems it works.
    Thank you to everybody else!
    Kurt



  • @K-Str if your issue is solved, please don't forget to mark your post as such! Thanks.



  • Hello,
    sorry, but the real problem has not been solved because I still do not know how to setup qt5-creator on a Windows 10 PC. See my post above (3 days ago).
    Maybe sombody has some experience with this problem.
    Kurt


Log in to reply