Important: Please read the Qt Code of Conduct -

Cannot find the androiddeploy Json file

  • Hi evrybody
    How can solve this error
    Cannot find the androiddeploy Json file.
    Error while building/deploying project heartrate-game (kit: Android for armeabi-v7a (GCC 4.8, Qt 5.9.6 for Android armv72))
    When executing step "Deploy to Android device"

  • I had this issue just last night. It relates to the "shadow build" option in the "Projects" tab within QtCreator.

    If you un-check the option and run qmake then re-build, it should work just fine.

  • Lifetime Qt Champion

    hi @webzoid,

    if its like this than it sounds like a bug. have you already checked if there is nothing, it might be worth to creare a report. please provide the link here.


  • @aha_1980 In typical fashion, I tried checking the "shadow build" option this morning (which didn't work the other day) and it works now.

    Thinking about it actually, it may also have been an issue with the JDK I had installed. I downloaded the latest JDK which was version 10.0.1 and this did NOT work at all. Reverting back to version 8 seemed to help and it could well have been at the same time as getting the androiddeploy.json file issue.

    So much for me changing one thing at a time...

    @ali1354 What version of the Java JDK/JRE are you using?

  • I am having the same issue, and i opened a support request,
    i am trying to deploy to my galaxy S6 phone an app of mine.
    The first reply said that there are missing dependencies for the application i am deploying. HTH.
    Btw i am using JDK 8.171 (oracle) with Qt 5.11.1 on linux.

    Btw, trying to deploy a newly created app, (blank and empty mainwindow) works as expected.

Log in to reply