Qt World Summit: Register Today!

Issues Installing QT5 Dependencies in Ubuntu

  • Hey Guys -

    I was planning to update my installation of Synergy in Ubunutu this morning to 1.10.x when I found that there were some dependencies not met. This isn't the first app that I've had issues with QT5 dependencies being the right version so decided to post using it as an example.

    My primary question is: is there a repo I can add, package to install, or whatever in order to install all libraries for a a version like 5.7.1? I see the full download for QT5 (which I'm not that familiar with) is 1.2gb - surely that whole thing isn't needed for a few grouped dependencies. Below is what I encountered this morning...

    One of the two needed dependencies for the DEB I was installing was libqt5core5a 5.7.1 and the OS's repo didn't have that version so found it's DEB, downloaded, and installed it. However, I found that with it, other dependencies were required which were libqt5gui5 (>= 5.0.2), libqt5network5 (>= 5.0.2), & libqt5widgets5 (>= 5.2.0~alpha1). These versions also weren't in my repos, so again had to download their debs and install. When installing them, I was prompted for more dependencies (yes, dependency of a dependency, or a dependency) which is when I decided to post. To note, Synergy doesn't have a repo that I am aware of and the version in my repos is extremely old so as far as I know, I must use DEB.

    Any suggestions? Thanks!

  • Lifetime Qt Champion

    Hi and welcome to devnet,

    What version of Ubuntu are you using ?

    How are you trying to install that Synergy package ?

  • Lifetime Qt Champion

    hi @BzowK,

    you have two options:

    1. build synergy from source code against Qt on your system. if the Qt from your package manager is too old, you can install the download from Qt website you already found
    2. use the deb package. as it seems to be built for another system, that may work or not. you can also try with a newer Qt than 5.7, as they are backward compatible.


  • @BzowK
    I don't know if this helps/can be applied to your situation, but FWIW I stuck to the Qt distributed with my distro (Ubuntu 17.10). That is 5.7, and I think not 5.7.1. I fetch all packages (compiled) from repos, have never compiled anything Qt, and have not experienced any version incompatibilities anywhere. When I migrate to Ubuntu 18.04 I will do the same, with whatever Qt version it supplies.

    So far as I can see, I got everything (non-Python) Qt via sudo apt-get install qt5-default​. Then all I had to add was sudo ​apt-get install libqt5sql5-mysql​ for the MySQL support I wanted.

    Of course, I don't know about your Synergy, you may be saying it requires a later version....

Log in to reply