Important: Please read the Qt Code of Conduct - https://forum.qt.io/topic/113070/qt-code-of-conduct

You cannot configure qt separately within a top-level build



  • I am getting this error continuously while trying to build Qt5.9.5 source for Raspberry-Pi 3. What can be the possible reason ?
    log is given below.

    Target os: Fedberry 27
    Toolchain: gcc-linaro-7.2.1-2017.11-x86_64_arm-linux-gnueabihf/

    bash-4.4$ ../configure -recheck-all -opengl es2 -device linux-rasp-pi2-g++ -device-option CROSS_COMPILE=/home/alokin/raspberry/gcc-linaro-7.2.1-2017.11-x86_64_arm-linux-gnueabihf/bin/arm-linux-gnueabihf- -sysroot /mnt/raspberry-rootfs -opensource -confirm-license -optimized-qmake -reduce-exports -release -make libs -prefix /usr -hostprefix /usr/local/Qt_5_9_5raspberry/ -skip qtwebengine

    • cd qtbase
    • /home/alokin/Qt5.9/qt-everywhere-opensource-src-5.9.5/qtbase/configure -top-level -recheck-all -opengl es2 -device linux-rasp-pi2-g++ -device-option CROSS_COMPILE=/home/alokin/raspberry/gcc-linaro-7.2.1-2017.11-x86_64_arm-linux-gnueabihf/bin/arm-linux-gnueabihf- -sysroot /mnt/raspberry-rootfs -opensource -confirm-license -optimized-qmake -reduce-exports -release -make libs -prefix /usr -hostprefix /usr/local/Qt_5_9_5raspberry/ -skip qtwebengine
      Preparing build tree...
      Creating qmake...
      ........................................................................................Done.
      Project ERROR: You cannot configure qt separately within a top-level build.


  • hello guys , finally iam able to build Qt after making two blank files named
    1.) .qmake.stash
    2.) .qmake.super
    in build directory. So the problem is happening due to not creating this two files in the configuring step. I don't know why configuring script is behaving like this.


  • Lifetime Qt Champion

    Hi
    You are not stating Qt version, platform etc so hard to geuss at.

    Might be this ?
    https://bugreports.qt.io/browse/QTBUG-56049



  • @mrjj But i don't have any .qmake.super file in my directory



  • @Vivx701 it looks like you're trying to cross compile (-device-option CROSS_COMPILE=...) so are you following this guide? It worked for me with Raspbian Stretch, Qt 5.10.1 and Pi Zero W
    Just in case, you stated "for Raspberry-Pi 3" but you shown configurating it for RPi 2 -> "-device linux-rasp-pi2-g++"



  • @Pablo-J.-Rogina Iam not building for rasbian . My target os is fedberry



  • @Vivx701 said in You cannot configure qt separately within a top-level build:

    fedberry

    Ok, it would be better to have stated it previously :-) (saving you and me a couple of posts...)

    Even with that, I guess the suggested guide would still apply from step #5 onwards, wouldn't it?



  • @Pablo-J.-Rogina : Still it gives the same error.



  • @Vivx701 @Vivx701 Wow! it looks like you were super fast creating your sysroot and rscync'ing it.
    Again, my suggestion is that you follow that guide step by step...



  • @Pablo-J.-Rogina : I just mounted my sd card under /mnt/raspberry-rootfs



  • @Vivx701 Ok, it's up to you. All I can say it's the guide helped me achieving the goal of cross-compiling Qt for RPi
    Roger over and out!


  • Lifetime Qt Champion

    Hi,

    You seem to be building Qt from within a directory that's inside the sources, is that correct ?

    If so, then that's likely the problem. You should build Qt either within the top folder of the sources or even better in a folder outside of the sources.



  • @SGaist Now i created a directory outside Qt source code and tried running this . see the output at the end same error.

    bash-4.4$ ../qt-everywhere-opensource-src-5.9.5/configure -recheck-all -opengl es2 -device linux-rasp-pi3-g++ -device-option CROSS_COMPILE=/home/alokin/raspberry/gcc-linaro-7.2.1-2017.11-x86_64_arm-linux-gnueabihf/bin/arm-linux-gnueabihf- -sysroot /mnt/raspberry-rootfs -opensource -confirm-license -optimized-qmake -reduce-exports -release -make libs -prefix /usr/local/Qt_595-raspberry/ -qt-libpng -qt-zlib -qt-libjpeg -qt-pcre -qt-freetype -skip qtwebengine -force-debug-info -nomake tests

    • cd qtbase
    • /home/alokin/Qt5.9/qt-everywhere-opensource-src-5.9.5/qtbase/configure -top-level -recheck-all -opengl es2 -device linux-rasp-pi3-g++ -device-option CROSS_COMPILE=/home/alokin/raspberry/gcc-linaro-7.2.1-2017.11-x86_64_arm-linux-gnueabihf/bin/arm-linux-gnueabihf- -sysroot /mnt/raspberry-rootfs -opensource -confirm-license -optimized-qmake -reduce-exports -release -make libs -prefix /usr/local/Qt_595-raspberry/ -qt-libpng -qt-zlib -qt-libjpeg -qt-pcre -qt-freetype -skip qtwebengine -force-debug-info -nomake tests
      Preparing build tree...
      Creating qmake...
      .Done.
      Project ERROR: You cannot configure qt separately within a top-level build.


  • @SGaist This time iam trying to build with in Qt source code directory , see the output . same error

    ./configure -recheck-all -opengl es2 -device linux-rasp-pi3-g++ -device-option CROSS_COMPILE=/home/alokin/raspberry/gcc-linaro-7.2.1-2017.11-x86_64_arm-linux-gnueabihf/bin/arm-linux-gnueabihf- -sysroot /mnt/raspberry-rootfs -opensource -confirm-license -optimized-qmake -reduce-exports -release -make libs -prefix /usr/local/Qt_595-raspberry/ -qt-libpng -qt-zlib -qt-libjpeg -qt-pcre -qt-freetype -skip qtwebengine -force-debug-info -nomake tests

    • cd qtbase
    • /home/alokin/Qt5.9/qt-everywhere-opensource-src-5.9.5/qtbase/configure -top-level -recheck-all -opengl es2 -device linux-rasp-pi3-g++ -device-option CROSS_COMPILE=/home/alokin/raspberry/gcc-linaro-7.2.1-2017.11-x86_64_arm-linux-gnueabihf/bin/arm-linux-gnueabihf- -sysroot /mnt/raspberry-rootfs -opensource -confirm-license -optimized-qmake -reduce-exports -release -make libs -prefix /usr/local/Qt_595-raspberry/ -qt-libpng -qt-zlib -qt-libjpeg -qt-pcre -qt-freetype -skip qtwebengine -force-debug-info -nomake tests
      Creating qmake...
      .Done.
      Project ERROR: You cannot configure qt separately within a top-level build.

  • Lifetime Qt Champion

    Are you doing that from clean sources ?

    If not, you should nuke them as well as the build folders you used and start over with an out of source build.





  • hello guys , finally iam able to build Qt after making two blank files named
    1.) .qmake.stash
    2.) .qmake.super
    in build directory. So the problem is happening due to not creating this two files in the configuring step. I don't know why configuring script is behaving like this.



  • Adding .qmake.super seemed that have fixed my issue as well. Has anyone found out why it wasn't created to begin with?


Log in to reply