Important: Please read the Qt Code of Conduct -

Raspberry Touch input issue

  • Hi,
    I crosscompiled Qt 5.7.0 Win10-raspberry. It's working. But i have been dealing with some issues:

    1. Touch freeze (10in Waveshare monitor purchased on DigiKey) when digital output activates an AC motor driver (of course with the proper electronics and isulation) Notice that is not the Qt application nor the monitor (the image itself) it's only the touch. First i thought "Oh, ok, maybe is noise. It's not an industrial grade monitor, etc." But then i tried with a 7in touch screen monitor of the same brand and works fine, I mean is not the best quality monitor, but it works as it's suppoused to. So my conclusion was: bad luck, a faulty monitor.
      What do you think? someone have had the same problem? any advice?

    2. The touch calibration. Given the problem mention above, I tried with an ELO touch monitor. Ugly resolution in my opinion, anyway. The touch worked, i used xinput_calibrator command and worked. BUT when i started the application the touch input was totally messed up. More or less, because it appeared to be to sensitive and scaled on reference of the rigth-top corner.
      So I thought: "The app does not know how to use the input touch, and read only raw data". Then I changed to ts_lib, run calibration, check the config file, test the calibration, set the tons (ok, just a few) of environmental variables in Qt to tell the application to use ts_lib, the path of the corresponding files, etc, etc. BUT nothing worked. Not even a little, literally. It behaved exactly the same way.

    3. The previous 10in WaveShare monitor touch now does not work properly. The machine i was controlling with the Raspberry was to be delivered, so I install back the original monitor and use wireles Logitech Keyboard. so far so good. But the touch of the monitor wich was prevously working (except for the freeze ) now was not. I readjust the /boot/config.txt file and recalibrate with xinput_calibrator. It seemed to work, until I opened the Qt application and again the touch input was messed up. I tried unsetting the environmental variables related with ts_lib , and actually all varaibale that i have previosly used. But nothing. It never worked as the beginning.

    I know that since Raspberry is an embedded device it uses EGFLS which i understand is the interface between some sort of windows manager of the SO and OpenGL rendering. Correct me if i'm wrong.
    Qt documentation does not really help, or i'm searching in the wrong way.
    So, what i'm missing? how can i have full control of my application response despite the monitor and/or touch connected?
    I guess it's not a drivers issue, because the touch works fine in the OS, but not in the Qt application. Again, correct me if i'm telling non-sense, please.

    Also the on-screen keyboard does not work, the pulgin loads but is not shown. And i'm pretty sure is because i'm running on EGLFS. I don't even know what the letters mean.

    My apologize if i'm asking silly questions, i really don't know what is happening. .

    Thank you for reading, and thank you in advance for your advices.