Can't configure Qt Creator with MSVC 2015 compiler



  • I installed Qt 5.7.1 msvc2015 x64. I have the MSVC 2015 compilers installed for C++ and can compile C++ code in Visual Studio. Somehow I'm unable to configure QtCreator despite of having the right combination of Qt and Visual Studio (I'm pretty sure about this). I now have a red warning sign as seen in the images. It says no compiler can produce code for this Qt version.

    I had this combination running fine on my previous laptop. After upgrading my laptop, I had to re-install everything and somehow I'm stuck here. Is there anything I'm missing here? Any help would be greatly appreciated!! Thanks!4_1522116420953_Qt Versions.PNG 3_1522116420952_Kits.PNG 2_1522116420952_Debugger.PNG 1_1522116420951_Compilers.PNG 0_1522116420950_Cmake.PNG


  • Moderators

    @darkhorse Did you try to add a Kit manually?
    And I'm wondering about compiler version 15.0 - Visual Studio 2015 C++ compiler is actually 14.0.
    Are you sure you installed VS2015?


  • Moderators

    @darkhorse said in Can't configure Qt Creator with MSVC 2015 compiler:

    I have the MSVC 2015 compilers installed for C++

    @jsulm is right. "Microsoft Visual C++ Compiler 15.0" is MSVC 2017, not MSVC 2015.



  • My bad, I worded that wrong. I have Visual Studio 2017 and Visual C++ Compiler 15.0 ie MSVC2017. But I don't believe there was a Qt MSVC2017 version ever. Is there a way I can make it work with the current version of Qt 5.7.1 MSVC2015 x64?

    Visual Studio: 2017 Professional
    Qt: 5.7.1-msvc2015-x64


  • Lifetime Qt Champion

    Hi,

    Qt 5.10 at least has a 64 VS2017 pre-built package but 5.9 is also likely to have it.

    What you have to do is to create a new kit where you set your VS2015 but configure the VS2017 compiler.



  • @SGaist and @jsulm : Thanks guys. Manually creating the kit solved the problem. But somehow Qt Creator kind of doesn't respond to any mouse clicks in the main IDE window, almost as if it has frozen. The toolbar responds fine. Can't build, class files don't load. I'm not sure what this is related to, my project or Qt itself. This same setup project worked fine initially on Qt Creator.


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.