Camera support Raspberry Pi



  • HI,

    I'm struggling to get the camera examples to work when compiling on the Raspberry Pi.

    When I run a clean configure I get the following output which I'm assuming is the issue, I'm compiling directly on the Pi...

    Qt Multimedia:
    ALSA ................................... yes
    GStreamer 1.0 .......................... no
    GStreamer 0.10 ......................... no

    Is there any documentation on which packages are required to build with Gstreamer support? I have the following installed...

    gir1.2-gstreamer-0.10
    gir1.2-gstreamer-1.0
    gstreamer-tools
    gstreamer0.10-alsa:armhf
    gstreamer0.10-gconf:armhf
    gstreamer0.10-plugins-bad:armhf
    gstreamer0.10-plugins-base:armhf
    gstreamer0.10-plugins-good:armhf
    gstreamer0.10-tools
    gstreamer0.10-x:armhf
    gstreamer1.0-alsa:armhf
    gstreamer1.0-clutter
    gstreamer1.0-doc
    gstreamer1.0-fluendo-mp3:armhf
    gstreamer1.0-gnonlin
    gstreamer1.0-gnonlin-dbg
    gstreamer1.0-gnonlin-doc
    gstreamer1.0-libav:armhf
    gstreamer1.0-libav-dbg:armhf
    gstreamer1.0-nice:armhf
    gstreamer1.0-omx
    gstreamer1.0-omx-dbg
    gstreamer1.0-packagekit
    gstreamer1.0-plugins-bad:armhf
    gstreamer1.0-plugins-bad-dbg:armhf
    gstreamer1.0-plugins-bad-doc
    gstreamer1.0-plugins-base:armhf
    gstreamer1.0-plugins-base-apps
    gstreamer1.0-plugins-base-dbg:armhf
    gstreamer1.0-plugins-base-doc
    gstreamer1.0-plugins-good:armhf
    gstreamer1.0-plugins-good-dbg:armhf
    gstreamer1.0-plugins-good-doc
    gstreamer1.0-plugins-ugly:armhf
    gstreamer1.0-plugins-ugly-dbg:armhf
    gstreamer1.0-plugins-ugly-doc
    gstreamer1.0-pulseaudio:armhf
    gstreamer1.0-tools
    gstreamer1.0-vaapi:armhf
    gstreamer1.0-vaapi-doc
    gstreamer1.0-x:armhf
    libgstreamer-plugins-bad0.10-0:armhf
    libgstreamer-plugins-bad1.0-0:armhf
    libgstreamer-plugins-base0.10-0:armhf
    libgstreamer-plugins-base0.10-dev
    libgstreamer-plugins-base1.0-0:armhf
    libgstreamer-plugins-base1.0-dev
    libgstreamer-vaapi1.0-0:armhf
    libgstreamer-vaapi1.0-dev
    libgstreamer0.10-0:armhf
    libgstreamer0.10-dev
    libgstreamer1.0-0:armhf
    libgstreamer1.0-0-dbg:armhf
    libgstreamer1.0-dev
    libqtgstreamer-0.10-0:armhf
    libqtgstreamer-dev
    libqtgstreamerui-0.10-0:armhf
    libqtgstreamerutils-0.10-0:armhf

    Thanks in advance!


  • Moderators

    @gforeman Try to call configure with -v parameter, then you will get more information about what is missing.



  • Thanks for that, I'm getting this...

    Trying source 0 (type pkgConfig) of library gstreamer_1_0 ...
    pkg-config use disabled globally.
    => source produced no result.
    test config.multimedia.libraries.gstreamer_1_0 FAILED
    Checking for GStreamer 0.10...
    Trying source 0 (type pkgConfig) of library gstreamer_0_10 ...
    pkg-config use disabled globally.
    => source produced no result.
    test config.multimedia.libraries.gstreamer_0_10 FAILED

    WARNING: Cross compiling without sysroot. Disabling pkg-config

    I'm using CROSS_COMPILE=/usr/bin/ as a configure parameter, is there another parameter I need to supply?



  • For anyone with the same issue I added -sysroot / to the configure line and gstreamer was found.

    I guess this is required as CROSS_COMPILE is in the configure line.



  • I don't suppose you can link to a tutorial/step-by-step you used to successfully compile directly on the Pi? I've tried just about every tutorial I could find and haven't had any success thus far.



  • @jars121 I used this https://wiki.qt.io/Native_Build_of_Qt5_on_a_Raspberry_Pi guide and got it complied successfully on a raspberry Pi 3.

    The only changes were I didn't need to edit the QT_CFLAGS settings as outlined in the guide and I added -sysroot / to the configure. My configure skipped quite a few modules though so was probably less likely to encounter errors, compiling takes forever on the Pi so its worth skipping unnecessary modules.


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.