Some issues with deployment on Linux with 5.8



  • Since I switched to 5.8 from 5.6.2 I am having some issues with deployment.

    • first issue is that dialogs or any extra windows opened besides main window are not rendered in virtualbox
    • 2nd issuse is that the application is searching for Private/EditMenu_base.qml it in the path where the build was made and not in where the application is deployed and according to my qt.conf file, yet every other files are detected and load correctly.

    Any ideeas on how I might solve these issues or how I can try to find a way?



  • In response to first question - I think that VB is stupid idea for programming app.


  • Lifetime Qt Champion

    Hi,

    @adutzu89 Can you explain how you are doing the deployment ?
    As for your first question, is it working properly with in virtualbox with Qt 5.6.2 ?

    @Pyroxar that's not an really helpful answer, you should back such affirmations with proofs.



  • @Pyroxar said in Some issues with deployment on Linux with 5.8:

    In response to first question - I think that VB is stupid idea for programming app.

    I am not looking for personal opinions.
    I will keep using my stupid ideea for fast testing my applications, thank you.



  • @SGaist

    It used to work previously, so it's not on the Qt part(I'm assuming).
    Before upgrading to Qt 5.8 I also reinstalled my OS and deleted old virtual machine(because I had made the disk fixed and had issue with space) and most likely something is missing.
    In live usb version of the OS and other linux distributions it works, but not in virtual machine.
    I tried deploying the build folder with dependencies in the following directories: lib, qml, plugins as they are named in the qt.conf file added to the resource system in :/qt/etc/qt.conf.
    Here is how I define the content inside qt.conf:

    [Paths]
    Libraries = lib
    Plugins = plugins
    Qml2Imports = qml
    

    I have also tried making an offline installer using the Qt installer framework.


  • Lifetime Qt Champion

    Then you should test the OpenGL stack from your virtual machine, it happens pretty easily that by default the hardware acceleration is disabled which can have side effects on QML application since they require OpenGL ES2 at minimum.



  • @SGaist

    The virtual machine has 3d acceleration enabled, I have installed dkms, build-essentials and then install guest aditions.
    I have also installed libgles2-mesa, libgles2-mesa-dev, libgles2-mesa-dev-lts-xenial, libgles2-mesa-lts-xenial and still not working.

    Any other ideeas?


  • Lifetime Qt Champion

    Did you check with e.g. glxgears that you have 3D acceleration working ?



  • @SGaist
    Will check when I get home, another thing which I noticed, If I move the dialog on top of the main ApplicationWindow I can see the content of the dialog.



  • @SGaist Sorry for the late response, tried it and works.


  • Lifetime Qt Champion

    I'd recommend taking a look at the linuxdeployqt project. It might help with your deployment issue.


Log in to reply