New install, Problems compiling some examples



  • I have a new instal on a windows 7 machine with visual studio
    Being new to Qt I have tried running some of the examples e.g Qt Quick Demo-Clocks, Map Viewer (QML)
    but when I have tried for instance Qml Oscilloscope I get this from the compiler output

    14:10:16: Running steps for project qmloscilloscope...
    14:10:16: Configuration unchanged, skipping qmake step.
    14:10:16: Starting: "C:\Qt\Tools\QtCreator\bin\jom.exe"
    C:\Qt\Tools\QtCreator\bin\jom.exe -f Makefile.Debug
    cl -BxC:\Qt\5.8\msvc2013_64\bin\qmake.exe -nologo -Zc:wchar_t -FS -Zi -MDd -GR -W3 -w34100 -w34189 -w44996 -E -Za ........\5.8\msvc2013_64\mkspecs\features\data\dummy.cpp 2>NUL >debug\moc_predefs.h
    The system cannot find the path specified.
    jom: C:\Qt\Examples\Qt-5.8\charts\build-qmloscilloscope-Desktop_Qt_5_8_0_MSVC2013_64bit-Debug\Makefile.Debug [debug\moc_predefs.h] Error 1
    jom: C:\Qt\Examples\Qt-5.8\charts\build-qmloscilloscope-Desktop_Qt_5_8_0_MSVC2013_64bit-Debug\Makefile [debug] Error 2
    14:10:16: The process "C:\Qt\Tools\QtCreator\bin\jom.exe" exited with code 2.
    Error while building/deploying project qmloscilloscope (kit: Desktop Qt 5.8.0 MSVC2013 64bit)
    When executing step "Make"
    14:10:16: Elapsed time: 00:00.

    and this output from the General messages

    Module path: C:/Qt/5.8/msvc2013_64/qml/QtGraphicalEffects
    See "Using QML Modules with Plugins" in the documentation.

    Automatic type dump of QML module failed.
    Errors:
    "C:\Qt\5.7\msvc2013_64\bin\qmlplugindump.exe" returned exit code 3.
    Arguments: -nonrelocatable QtGraphicalEffects 1.0 .
    QQmlComponent: Component is not ready
    file:///C:/Qt/5.8/msvc2013_64/qml/typelist.qml:2:1: plugin cannot be loaded for module "QtGraphicalEffects": The plugin 'C:/Qt/5.8/msvc2013_64/qml/QtGraphicalEffects/qtgraphicaleffectsplugin.dll' uses incompatible Qt library. (5.8.0) [release]

    I feel that I have a missing component or the answer is right in front of me. any help with this would be apreciated


  • Moderators

    @wazza Do you have Visual Studio 2013 and its C++ compiler installed on your machine?



  • I have visual studio 2013 installed I also installed 2017rc last night to see if the issue was there


  • Moderators

    @wazza This error message says that it cannot find a path:
    "
    C:\Qt\Tools\QtCreator\bin\jom.exe -f Makefile.Debug
    cl -BxC:\Qt\5.8\msvc2013_64\bin\qmake.exe -nologo -Zc:wchar_t -FS -Zi -MDd -GR -W3 -w34100 -w34189 -w44996 -E -Za ........\5.8\msvc2013_64\mkspecs\features\data\dummy.cpp 2>NUL >debug\moc_predefs.h
    The system cannot find the path specified."
    Can you check all mentioned paths - whether they exist? For example: does C:\Qt\Tools\QtCreator\bin\jom.exe exist?



  • C:\Qt\Tools\QtCreator\bin\jom.exe Exists in the path
    C:\Qt\5.8\msvc2013_64\bin\qmake.exe Exsits
    \5.8\msvc2013_64\mkspecs\features\data\dummy.cpp Exsits
    moc_predefs.h is the only file that i cant find !


  • Moderators

    @wazza What about "cl" - the compiler?



  • @jsulm HI jsulm I think you might have it!
    I can't find cl.exe for visual studio 2013 I have it for 2012 and 2017
    I selected c++ in the modified instal for 2013 but it's just not there
    do you have an idea on how to get it in there I might have to reinstall


  • Moderators

    @wazza C++ tools are not installed by default. I think you need to start the installer again and select C++.



  • @jsulm I have reinstalled msvs2012, and it installed it in a file that is labelled
    Microsoft Visual Studio 12.0\VC\bin that was there previously but I had assumed was an
    older studio, so cl.exe is there! we are back to square 1


  • Moderators

    @wazza Che3ck the Kit in QtCreator you're using: are there any warnings/errors?



  • @jsulm when I first installed qt the only kit warning was for the cdb.exe debugger and I just pointed it to the debugger yesterday


  • Moderators

    @wazza One moment: didn't you install Qt for VC2013 and not 2012? If so then you need VC2013 compiler.



  • @jsulm Yes it is installed qt for VC2013 I have installed VC2013 with the c++ cl.exe it is just installed in a path labelled C:\Program Files (x86)\Micrsoft Visual Studio 12.0\VC\bin the 12.0 is the version number of VC2013 as 2013 spand two versions 11.0 and 12.0


  • Moderators

    @wazza OK, I saw "I have reinstalled msvs2012".
    Can you create a simple console project in QtCreator and try to build it (without changing anything)?



  • @jsulm yes sorry about that, yes I can do simple console application and it builds and runs without a problem
    (well except for a missing ; my bad ) also other c++ applications in the examples are ok as well and I have noticed the ones that are not building and giving problems are some of the QML and data visualisation examples
    i have built some of the qml examples and the build ok



  • @jsulm I have uninstalled everything and just installed VC2015 and then installed qt5.8 MSVS2015 and the examples build and run without issues. it was a whole day operation! but thank you for all the help and the questions you asked helped me to understand the way QT works.


  • Qt Champions 2016

    @wazza said in New install, Problems compiling some examples:

    Understand the way QT works.

    Actually its not really related to Qt but how DLLS works.
    a DLL contains code, both functions, and classes.
    To use the classes from another app, then both app and DLL should be compiled with
    somewhat THE SAME compiler as else it cannot use these classes at all.

    So that is why
    Qt2015 MUSt be with VS 2015 compiler
    or
    Qt mingw must be with mingw compiler
    and that Qt 20143 do not work with Vs 2015 :)



  • @mrjj I was using QT2013 with VS2013 as I have had vs2013 and vs2012 installed on this machine for over 3 years I used the online installer and it installed qt5.8MSVS2013 kit I had the c++ compiler package installed on both VS packages and I do believe that is where the issues were orriganating. the issue was resolved once I uninstalled the VS packages and Qt I the installed VS2015 with C++ and the offline Qt installer for 5.8 MSVS2015.
    when I referred to how qt works I meant how the build process works with the packages his questions forced me to look under the hood so to speak


  • Qt Champions 2016

    @wazza
    Ok :)
    I didnt know that "2013 spands two versions 11.0 and 12.0"
    Thats good info.


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.