Deploying with linuxdeployqt tool



  • Hello..I am trying to deploy my Qt application through linuxdeployqt by following this video -> https://www.youtube.com/watch?v=PDzlT_ODpM8. In the video at 8:56 he runs a command,I am getting some errors while running the same command but changing with my system requirements.These are the errors:

    "/tmp/.mount_DB5n6w/usr/bin:/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games:/usr/local/games"
    app-binary: "/home/billy/build-src-Desktop_Qt_5_7_0_GCC_64bit-Debug/simple-player"
    ERROR: ldd outputLine: "/home/billy/build-src-Desktop_Qt_5_7_0_GCC_64bit-Debug/AppRun: /usr/lib/x86_64-linux-gnu/libQt5Core.so.5: version `Qt_5.7' not found (required by /home/billy/build-src-Desktop_Qt_5_7_0_GCC_64bit-Debug/AppRun)"
    ERROR: ldd outputLine: "/home/billy/build-src-Desktop_Qt_5_7_0_GCC_64bit-Debug/AppRun: /usr/lib/x86_64-linux-gnu/libQt5Core.so.5: version `Qt_5' not found (required by /home/billy/build-src-Desktop_Qt_5_7_0_GCC_64bit-Debug/AppRun)"
    ERROR: ldd outputLine: "/home/billy/build-src-Desktop_Qt_5_7_0_GCC_64bit-Debug/AppRun: /usr/lib/x86_64-linux-gnu/libQt5Gui.so.5: version `Qt_5' not found (required by /home/billy/build-src-Desktop_Qt_5_7_0_GCC_64bit-Debug/AppRun)"
    ERROR: ldd outputLine: "/home/billy/build-src-Desktop_Qt_5_7_0_GCC_64bit-Debug/AppRun: /usr/lib/x86_64-linux-gnu/libQt5Widgets.so.5: version `Qt_5' not found (required by /home/billy/build-src-Desktop_Qt_5_7_0_GCC_64bit-Debug/AppRun)"
    
    

    Can anybody tell me why I am getting this errors and suggest me some solution for this? Thanks!!


  • Lifetime Qt Champion

    Hi,

    Looks likes it's finding your system Qt rather than the one you installed, isn't it ?

    Note that this tool isn't yet part of Qt.



  • @SGaist Thanks for replying.Can you tell me how to change the qt path to installed sdk path and how to deploy my application without that tool?Thanks


  • Lifetime Qt Champion

    I'd try why setting LD_LIBRARY_PATH before calling linuxdeployqt.



  • @SGaist Can you tell me how to set that path? Thanks!



  • Hi @abhay,

    I have no experience with linuxdeployqt , however, a couple of things I'd try:

    1. check that qmake -v is showing the same Qt version you built the app with. For example, if you used Qt Creator and/or the Qt installer, its quite liekly that Qt Creator is setup to use a more recent Qt version, while your shell (which, presumably, linuxdeployqt is running in) is providing an older Qt version. Based on the error message, I'd guess that you don't even have the OS's Qt libraries installed, which is fine... in this case you probably need to add the Qt installer's qmake to your path, so that it gets used in preference to the OS's. Anyway, run qmake -v and compare the output to the version of Qt that you used to build your app.

    2. if that all looks correct, try linuxdeployqt's libpath opton... perhaps something like:

    linuxdeployqt app-binary --libpath=/path/to/your/qt/libs 
    

    Of course, you should also raise the question at linuxdeployqt/issues, if you haven't already :)

    Cheers.



  • This post is deleted!


  • @Paul-Colby Thanks for your suggestion!It worked!


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.