QT Creator / Open Source QT App/Installer/Uninstaller Hangs



  • I've tried installing, uninstalling and running QT Creator and Open Source a few times within the past week. The primary issue is that my Creator corrupted after about two months of not being used.

    After my .dll files for compiling were not found, I began having issues like... QT could not be opened twice in the same instance of Windows being booted (like there is a global variable that hangs). The same issue goes for uninstalling and installing. I realized the problem when I went to fix my .dll problem...

    I uninstalled QT creator and couldn't uninstall QT Open Source. Then I noticed my startbar had 20 instances of Linguistics, Designer, etc. Following this, I restarted my computer, uninstalled QT Open Source , tried to reinstall Creator and it hung up again. Restarted, installed Creator, tried to run it, and it hung. Force quit and tried to run Creator again, hung. Restarted, uninstalled, tried to reinstall, hung.

    What is the issue?? This appears to be a massive bug and I can't work on my code for my project!


  • Qt Champions 2016

    Hi and welcome
    Can you please write
    platform
    Qt version
    Compiler used
    how you got Qt/what you downloaded

    It sounds a bit odd.

    You checked that:
    1: no virus scanner is blocking stuff. ( im looking at you avast :)
    2: you didnt install other Qt program that might have installed Qt dlls



  • @mrjj Absolutely!

    Windows 10
    QT Creator 4.0.0
    I had a ton of compilers installed including but not limited to:
    MinGW4.3.0 (x86)
    MinGW4.4.0 (x86)
    OpenGL (x86)

    I got Creator from... I believe www.qt.io.
    I had also received another installation for utilizing the maintenance tool for downloading these compilers from qt.io. I know for a fact I got this open source package from www.qt.io. This package did in fact work with creator, before the Anniversary Update for Windows 10.

    However, I've uninstalled all QT programs from my computer and am still having issues.

    I do not have an anti-virus outside of windows defender. I have anti-maleware (MBAM), which causes no issues.


  • Qt Champions 2016

    @crisosphinx said:

    Anniversary Update

    Oh, is it posssible it broke something?
    I have not yet gotten this huge upgrade :)



  • @mrjj I thought it might've, but I set my build back to a previous build (before the Anniversary / Annual update) and the issue was, and currently is, still prevalent.


  • Qt Champions 2016

    @crisosphinx
    hmm. its hard to guess as it can be many things then.
    have you tried
    https://www.qt.io/download-open-source/#section-2
    Qt 5.7.0 for Windows 32-bit (MinGW 5.3.0, 1.1 GB) (info)
    This one has yet to fail me to just work out of the box.



  • @mrjj I'll give that a try when I get home. Nothing seemed to have worked earlier when I downloaded the new Open Source installation from QT (might be the same installation file). It was running the same way it did for my other installations (installing then needing a reboot to even get it running).

    Is this, perhaps, just a problem with Windows?


  • Qt Champions 2016

    @crisosphinx
    well it could just be a local windows issue.
    I have installed in on 8+ windows 10 machines and never had it hang as you say it does for you.
    Not that it means it cant have issue. but seems pretty severe what u experience.

    Does it have opengl support , your pc?



  • @mrjj Yeah, my computer supports all engines (I'm primarily an artist/ game artist/ animator). I just did a little bit more research and it seems it could be an issue with the Windows 10 Anniversary Update:

    http://news.thewindowsclub.com/windows-10-anniversary-update-reportedly-causing-problems-for-many-85564/

    Apparently, many drivers are malfunctioning on computers. I guess my PC is temporarily crippled, eh?


  • Qt Champions 2016

    @crisosphinx
    ok so it has opengl for sure. :)
    I so hope the damage is limited to Creator/Qt and not any huuuge adobe
    suit you have installed.

    thx for the feedback.
    maybe I should delay update a bit ;)



  • @mrjj I would very much hold off.

    I have to go back and check to see what is corrupted. It seemed like QT took the pain, for the most part. Not sure why an uninstall and reinstall wouldn't fix the issue... Not to mention, I don't know why the installer and uninstaller for QT, specifically, aren't working. Everything else works just fine. :'(

    I have yet to check Visual Studio (if that's corrupted, then my system needs to be reformatted).

    But I'll keep this updated, I suppose.

    If you, or the community, have any ideas as to what might need to be done to fix the issue (if it is in fact QT or not), I would very much appreciate any information hunting as possible. This project was mandatory for me to work on right now, so it's a huge hassle that I'll have to boot a secondary computer to run just the compiler and software...



  • @mrjj I just realized I posted this in the wrong forum... Can it be moved to the Installer/ deployment forum?


  • Qt Champions 2016

    @crisosphinx
    Heh. didnt even notice :)
    Good catch.



  • @mrjj Sometimes it's hard to see on mobile, Haha.


  • Qt Champions 2016

    @crisosphinx
    yeah, but im sitting at home on 27" screen ;)



  • I FIXED IT.

    To cut a long description down to a short, few lines... I enabled developer mode in Windows 10 with the Anniversary Update. It seems to have done the trick, as now I can fully operate and run QT Creator, the compilers, etc.

    Here is the link to enabling developer mode / Linux Bash within Windows:

    http://www.howtogeek.com/249966/how-to-install-and-use-the-linux-bash-shell-on-windows-10/

    It's a quarter way down the webpage, see. How to Install Bash on Windows 10.

    Honestly, I have no idea why they did this, but if having enabled this does the trick, then I'm not complaining.

    Cheers to anyone who has this issue in the near or far future!!!


  • Qt Champions 2016

    hehe
    so installing a linux sub system made windows 10 happy to run Creator again..
    If that is not slightly ironic, i dont know what is :)



  • @mrjj Haha! Well, I'm not sure if enabling Bash was the reason behind it, but enabling developer mode definitely had to have helped. :)

    At least it's fixed!



  • Nevermind, the issue has come back with a vengeance. I am trying to figure the problem out now.



  • The issue is officially solved.

    Below are a list of issues I encountered along the way and the full resolution I came to after long hours of debugging...

    Issues:

    • Windows 10 Anniversary Update killed the environment variables. It may be important to reconfigure / link / delete the current entries / paths for compilation. Link for where to find your Environment Variables.

    • Windows 10 Anniversary Update also created a hang up in some drivers that led to stalling of the code execution for QT Creator and Designer. Be aware of some conflicting drivers or programs (even if they are unrelated to QT / do not use QML or GUI provided by QT).

    • If you are an artist or utilize Wacom Tablets and their software for navigating your desktop (as opposed to a mouse). Please be aware that having more than one Tablet software installed, regardless of it running or being disabled, will cause conflicts.

    • In addition to the above issue, be aware that the Windows 10 Anniversary Update also created a glitch (at least in my installation) that caused the Tablet software to stall on boot of my computer. By failing, it caused a memory leak issue that resulted in QT not functioning. So, if you are experiencing issues similar to mine, uninstall all Tablet software and reinstall the one you use the most, be it Cintiq, Bamboo, Intuos, etc.

    Fix:

    • I rolled back my Win10 installation. It still had hang ups. I redirected the Environment Variables to the correct locations and uninstalled QT (all forms of it), uninstalled my Tablet softwares, re-installed my Win10 Anniversary Update, installed only my Cintiq software, installed QT, double-checked the environment variables, fixed my boot manager to only include processes I knew I needed and rebooted.

    It appears to be working fine. A few of my compilers went missing along the way and so did a few brain cells. ;)

    I had more than a few programs not working, so it took about a weeks worth of effort to figure out which programs were causing problems with other programs. It originally looked like a Windows Defender problem, then the Tablets, then the Realtek drivers, then Visual Studio, then the Tablets again.

    Sorry for the lengthy post, but hopefully it will assist some people in the near future. Most of my issues stemmed from the Update and I expect that there will be more people with problems.



Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.