Important: Please read the Qt Code of Conduct -

Problems creating msvc2015 Kit

  • Re: Problems creating msvc2015 Kit
    I installed VS2015 and QT 5.7.0 and I have the same problem:
    In the Kits tab, it says there is no compiler defined for the Desktop Qt 5.6.0 MSVC2015 32 bit Kit. And if I try to define my own kit, selecting the Microsoft Visual C++ Compiler 14.0 (x86) for it, it still has the red stop sign and this time says "The compiler MSVC2015 14.0 (x86) (x86-windows-msvc2005-pe-32bit) cannot produce code for the Qt version Qt 5.6.0 MSVC2015 32-bit (x86-windows-msvc2015-pe-32bit)"
    VS2015 works I compile C++ projects and C# projects.
    Any Idea

  • For what it's worth, I've got exactly the same problem. Windows 10 64-bit, VS2015 community edition. I've just installed QT 5.7. QT Creator has set up a 64-bit kit, and a 32-bit kit with a red blob. Hovering over it gets me 'no compiler set in kit'. If I try to define a kit manually, the compiler selection dropdown is disabled. If I hover over the resulting manual kit in the kits list, I get "The compiler MSVC2015 14.0 (x86) (x86-windows-msvc2005-pe-32bit) cannot produce code for the Qt version Qt 5.7.0 MSVC2015 32-bit (x86-windows-msvc2015-pe-32bit)". Note the distinction between x86-windows-msvc2005-pe-32bit and MSVC2015 32-bit (x86-windows-msvc2015-pe-32bit) (emphasis added). Any chance of a fix or workaround for this? It's unusable as is.

    I've used QT4.* with VS2008 in the past, and I don't remember it being anything like as painful to set up as this.

    James Lothian

  • Lifetime Qt Champion

    Hi and welcome to devnet,

    You should take a look at the bug report system to see if it's something known. If not please consider opening a new report providing all the information you have found so far.

  • Moderators

    Hi @Ruggero and @jameslothian23,

    See for a possible solution (t_hunger is one of the engineers who works on Qt Creator).

  • Thanks, that seems to have done it. It would be good if this were listed as a known issue.

Log in to reply