"eglCreatePbufferSurface failed with error "

  • Hi. I'm trying to get Qt WebEngine work with eglfs_kms. However, it emits the
    following error:

    [0101/000155:ERROR:gl_surface_qt.cpp(419)] eglCreatePbufferSurface failed with error 
    [0101/000155:ERROR:command_buffer_proxy_impl.cc(182)] Failed to initialize command buffer service.
    [0101/000155:ERROR:webgraphicscontext3d_command_buffer_impl.cc(210)] CommandBufferProxy::Initialize failed.
    [0101/000155:ERROR:webgraphicscontext3d_command_buffer_impl.cc(229)] Failed to initialize command buffer.

    gl_surface_qt.cpp(419) is the following line:

            LOG(ERROR) << "eglCreatePbufferSurface failed with error ", GetLastEGLErrorString();

    The log doesn't include a EGL error string, so I think it's failing to call
    EGL functions. Any idea to fix the issue?

  • Solved: the cause was the stub in mesa3d drm backend. It's solved by altering the backend.

Log in to reply

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.