QtWebEngine doesn't work on Embedded Linux on rpi.



  • Hi, I'm trying to install Qt from the source code to Raspberry Pi Model B+ with Buildroot.
    I have succedded in building and installing, but it doesn't seem to work correctly.

    I used the demo browser application to test, but it can't finish loading and doesn't show the content. It shows the title of the page, so I think it's failing to draw the page. How can I fix it?

    The below is the environment.

    • Raspberry Pi Model B+ (ARM1176JZF-S, ARMv6 + VFP, 64MB RAM free)
    • Compiled for ARM state.
    • Using hard float ABI.
    • Buildroot 2016.02
    • Qt 5.5.1
    • OpenGL ES 2.0
    • eglfs of Qt Embedded Linux

    The below is the page source, located in file:///mnt/hello.html.

    <!DOCTYPE html>
    <html>
    	<header>
    		<title>Hello, World!</title>
    	</header>
    	<body>
    		Hello, World!
    	</body>
    </html>
    


  • Solved: Now I use wayland-egl and everything is fine.

    The Long Story to Get the Simple Solution:
    At first, I used raspberrypi-userland for OpenGL ES. However, it didn't work.

    I tried VC4 DRM driver in the next. I have struggled to get it work, and I opened an issue on the repository. Then anholt, the author of the driver,
    updated the Wiki. By following the Wiki, I finally succeeded in getting it work.

    mesa3d is necessary to provide OpenGL ES API, so I installed it with drm backend. However, it didn't work since eglCreatePbufferSurface is stubbed in the backend. So I had to use other QPA.

    Next, I tried X11 since Buildroot supports xcb backend, but neither did it work. I thought porting Wayland should be much easier than fixing the issue, and actually it is.



Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.