Error in Android deployment



  • Hi

    I'm unable to deploy to AVD (API 17) correctly because of the following error:

    17:01:39: The process "/home/hpctech-work/.Qt/5.5/android_armv7/bin/androiddeployqt" exited normally.
    
    17:01:39: Pulling files necessary for debugging.
    
    17:01:39: Package deploy: Running command "/home/hpctech-work/.Qt/android-sdk-linux/platform-tools/adb -s emulator-5554 pull /system/bin/sh: readlink: not found /home/hpctech-work/Desktop/build-Test2-Android_for_armeabi_v7a_GCC_4_9_Qt_5_5_0-Debug/app_process".
    
    17:01:39: Packaging error: Command "/home/hpctech-work/.Qt/android-sdk-linux/platform-tools/adb -s emulator-5554 pull /system/bin/sh: readlink: not found /home/hpctech-work/Desktop/build-Test2-Android_for_armeabi_v7a_GCC_4_9_Qt_5_5_0-Debug/app_process" failed.Exit code: 1
    
    17:01:39: Package deploy: Failed to pull "/system/bin/sh: readlink: not found" to "/home/hpctech-work/Desktop/build-Test2-Android_for_armeabi_v7a_GCC_4_9_Qt_5_5_0-Debug/app_process".
    
    17:01:39: Package deploy: Running command "/home/hpctech-work/.Qt/android-sdk-linux/platform-tools/adb -s emulator-5554 pull /system/lib/libc.so /home/hpctech-work/Desktop/build-Test2-Android_for_armeabi_v7a_GCC_4_9_Qt_5_5_0-Debug/libc.so".
    
    Error while building/deploying project Test2 (kit: Android for armeabi-v7a (GCC 4.9, Qt 5.5.0))
    
    When executing step "Deploy to Android device"
    
    17:01:39: Elapsed time: 01:45.
    

    I tried to reset my configurations and used another PC (fresh installation) but I always get same result!

    • OS: Linux Mint 17.2 x64 xfce
    • Qt: 5.5.1
    • Qt Creator: 3.5.1 (opensource)


  • i have also the same problem under debian 8 x64. i did see a post claiming it was qtcreator 3.5 issue and it was to be fixed with 3.51 but i see thats what you are running. i amm going to try a older ver of android sdk and see if that helps



  • There are lots of bug reports related to this issues - I've read it will be fixed in QtCreator 3.6

    E.g.
    https://bugreports.qt.io/browse/QTCREATORBUG-14201
    https://bugreports.qt.io/browse/QTCREATORBUG-15177
    etc...

    So, long story in short we have to wait for a while...


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.