Consistently getting TSMProcessRawKeyCode failed (-192) on installed application on OS X



  • I'm trying to create an installer for my application on OS X. Running the application from the compiled bundle after running macdeployqt on it goes fine. However, when I generate an installer with binarycreator, run the installer and try to run the installed application, I get a TSMProcessRawKeyCode failed (-192) error when I try to write in a TextEdit. I don't get the error when I run the application with admin privileges through sudo.

    Is this a bug or am I doing something horribly wrong here?

    Edit: Appears that simply moving the app bundle causes this



  • I managed to fix this to some extent one by deleting the app bundle from the build directory and running macdeployqt with the argument -executable=<Target>.app/Contents/MacOs/<Target>



  • I take that back, it stopped working again.



  • Still no progress, but if someone can reproduce this, please post a minimal reproducing project to https://bugreports.qt.io/browse/QTBUG-48555



  • The latest development is that I had over 254 files open at once. No wonder nobody else had encountered this.