Running app on Embedded Linux



  • Hi,

    I have developed an Qt application using Qt creator in Linux(ubuntu) and compiled it successfully. Now I want to run the same application on another linux/windows/embedded device. I have tried doing it for embedded device. I have downloaded the Qt libraries 4.7.3 for embedded Linux (204 MB) from the link http://qt.nokia.com/downloads.

    Then I started installing it by following the guide lines given at http://doc.qt.nokia.com/latest/qt-embedded-deployment.html

    I am trying to build the application statically because my application size is very less (less than 100 KB). I have completed the first step shown below successfully

    1. ./configure -static -prefix /path/to/Qt <other parameters>
    2. make sub-src

    But while executing second step I am getting lot of errors like shown below

    ./include/QtCore/qatomic_arm.h:131: Error: no such instruction: swpb %al,%d make[1]: *** [.obj/release-static/qabstractanimation.o] Error 1 make[1]: Leaving directory/home/pavan/Desktop/qt-everywhere-opensource-src-4.7.3/src/corelib'
    make: *** [sub-corelib-sub_src_target_ordered] Error 2

    I have installed the required tool chain (arm-linux-gcc-4.4.3). But still I cannot take things forward.

    By google I have understood that I need to compile the application using static libraries or shared libraries to run application on any device.
    Is it correct?

    The procedure I have tried it it correct? Please let me know how to run application developed on one system to run on another system


  • Moderators

    What do you mean by
    [quote author="coolguy" date="1305119220"]

    1. make sub-src
      [/quote]

    You have to "configure" Qt, run "make" and probably to "make install".
    These are three steps until you can start to compile your application.



  • Thanks for your reply. I have just followed the guidelines given in the link at http://doc.qt.nokia.com/latest/qt-embedded-deployment.html

    The difference between make sub-src and just make is that the former will build only the Qt libraries and the latter will build the libraries plus examples, demos and so on. The latter takes a lot longer to complete. So it is preferred to use make sub-src


  • Moderators

    Sorry, I did not read careful enough. I was over-looking that the problem occurs already in the make for compiling Qt.

    You should provide the complete configure command.



  • I could compile qt statically and now I got .exe file. I need to deploy on my embedded linux device (mini2440 board). But I could n't run the file. Please help me out how could I run a simple qt application written using QT Creator on embedded linux device.

    Thanks in advance


  • Moderators

    I am struggling a little with your decriptions.
    It is not clear what operation systems are you working on.

    What is your host OS?
    Where are you running QtCreator?
    You like to deploy on a linux device, right?

    Again, it would be good to know the complete configure command you have been using.


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.