Error: This version of PyQt5 and the commercial version of Qt have incompatible licenses.



  • I am trying to set up PyQt. I thinks I have the commercial license of QT when I run this:

    python ./configure.py --qmake="/home/walker/Qt/5.5/gcc_64/bin/qmake"

    If I look at the LICENSE file in QT is does not specifically say I have the commercial license. It says this (and a few hundred pages more):

    GPLv3 and LGPLv3

            GNU LESSER GENERAL PUBLIC LICENSE
    

    The Qt Toolkit is Copyright (C) 2014 Digia Plc and/or its subsidiary(-ies).
    Contact: http://www.qt.io/licensing


  • Lifetime Qt Champion

    Hi,

    How did you install Qt on your computer ?



  • Hello.

    I hope that Walker Rowe doesn't mind me hijacking his thread. I've installed several times both pyqt5 and pyqt4, with their corresponding qt core and this is the first time I'm getting the license errors. I've been looking over the internet but I didn't find much relating to this error, except for this practically newly created thread.

    In my case, I've installed Qt through this link: http://www.qt.io/download-open-source/ and pyqt5 alongside sip in a python virtual environment.

    $ wget http://sourceforge.net/projects/pyqt/files/sip/sip-4.16.8/sip-4.16.8.tar.gz
    $ wget http://sourceforge.net/projects/pyqt/files/PyQt5/PyQt-5.4.2/PyQt-gpl-5.4.2.tar.gz
    

    This is the console output after trying to configure PyQt:

    $ python configure.py --qmake '~/Apps/.Qt/5.5/gcc_64/bin/qmake'
    Querying qmake about your Qt installation...
    Determining the details of your Qt installation...
    This is the GPL version of PyQt 5.4.2 (licensed under the GNU General Public
    License) for Python 3.4.0 on linux.
    Error: This version of PyQt5 and the commercial version of Qt have incompatible
    licenses.
    

    I've done basically the same thing I've done in the past and, as far as I know, I'm with the correct Qt license. What can I do? I've tried deleting the Qt folder and reinstalling it again with the wizard.


  • Lifetime Qt Champion

    Hi and welcome to devnet,

    Maybe a silly idea but did you check whether you have an old license file around ?



  • @SGaist Thank you for welcoming me.

    I'm installing this again because I did a full system wipe (all my data and my OSs data); I don't have old files around that could be interfering with the newer installation of Qt/PyQt.

    Is there any way to know the dependencies the wizard installed so I can wipe the Qt installation and try again? I had a network error when downloading it; maybe that's the issue.


  • Lifetime Qt Champion

    Everything the wizard installs goes in the Qt folder created by him, there's nothing running around except maybe the license file



  • Thank you.

    Since I ran out of ideas and I don't want to waste too much time on this I just downgraded to PyQt4. I'm using ubuntu at the moment and installed qt4 from the repos.

    # apt-get install qt-sdk
    

    Everything is working fine now. Hope this will help someone else.



  • I've run into the exact same problem as described here for
    PyQt-gpl-5.4.2
    qt-unified-linux-x64-2.0.2-1-online.run
    -> /opt/Qt/5.5$ qmake --version
    QMake version 3.0
    Using Qt version 5.5.0 in /opt/Qt/5.5/gcc_64/lib

    As I'm forced to go with QT 5 for several reasons, this is a little bit anoying. Are there solution to get the GPL versions working together either in a Linux or Windows environment ?

    Thanks
    Syracus



  • @syracus I ran into the same problem under OSX. My local open source QT5 reports "Builder" instead of the expected "Open Source" for target_config.qt_licensee in PyQT's configure.py. The compilation goes through smoothly once you uncomment the offending lines though.



  • @qkthr pinging you directly in case you didn't get a notification from my earlier message.



  • @barbul - could you elaborate more on how you fixed this? I'm clueless as to how to get Qt5 to report anything but "Builder".



  • In the 'configure.py' script of PyQt, just comment out lines 2591 to 2594, where it compares whatever it thinks the Qt license type is to "Open Source"



  • Commenting out lines 2591 to 2594 in configure.py PyQt5.5.0 solved the problem. Successfully installed PyQt inside virtual environment on Os X with Python3.5, PyQt5.5 and Sip4.16.9 configurations.


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.