Problems with Open-Source Downloads read https://www.qt.io/blog/problem-with-open-source-downloads and https://forum.qt.io/post/638946

Need Qt3D in Version 5.3.0



  • Hello,

    I'm searching for the Qt3D sources with the version 5.3.0.
    If I download the repo code.qt.io/qt/qt3d.git I only the the following branches:

    • origin/5.5
    • origin/5.5.0
    • origin/HEAD -> origin/5.5
    • origin/dev
    • origin/qt4

    Where can I find 5.3.0?

    Best regards
    okieh


  • Lifetime Qt Champion

    Hi and welcome to devnet,

    You won't, the latest version of Qt3D is officially in tech preview with Qt 5.5. AFAIK, your best bet is to use the 5.0.0-beta1 branch because the latest version requires Qt 5.5


  • Moderators

    @okieh said:

    Where can I find 5.3.0?

    Hi,

    Qt 3D was not yet finished at the time of Qt 5.3.0.

    It will be available in Qt 5.5 as a technology preview: https://wiki.qt.io/New_Features_in_Qt_5.5 After that, it will become a fully-supported module in Qt 5.6.

    If you want to stick to Qt 5.3, you could try downloading the 5.5.0 source code and building it yourself using Qt 5.3. However, this has not been tested and I don't know it will work.



  • Thanks for the fast replies!

    I'm a little bit confused... In my sysroot directory for my target (i.mx6) I have Qt in version 5.2.1 and Qt3D libs with Version 5.3.0. Now I need to setup my development computer under the same conditions.

    I already tried to build the Qt3d 5.5 version with my Qt 5.2.1 dev enviroment, but it doesn't work.

    It's not possible for me to work with other versions :-(

    Edit: cat of qt3dversion.h
    <code>
    /* This file was generated by syncqt. */
    #ifndef QT_QT3D_VERSION_H
    #define QT_QT3D_VERSION_H

    #define QT3D_VERSION_STR "5.3.0"

    #define QT3D_VERSION 0x050300

    #endif // QT_QT3D_VERSION_H
    </code>


  • Moderators

    @okieh said:

    I'm a little bit confused... In my sysroot directory for my target (i.mx6) I have Qt in version 5.2.1 and Qt3D libs with Version 5.3.0.

    Those Qt 3D libs are not officially-provided by the Qt Project, and they're incomplete.

    Perhaps you can ask the person who built those libs?

    I already tried to build the Qt3d 5.5 version with my Qt 5.2.1 dev enviroment, but it doesn't work.

    Why not? What errors do you get?


Log in to reply