[SOLVED] gcc not recognized in QT after installation



  • Hi,
    after successfully working with QT on windows7 now i am trying to do the same on linux.
    My System is Ubuntu 14.04, QT5.4.1 and gcc4.8.2

    I have installed gcc via terminal and i have no idea how to find the location for configuring it as the compiler in qt.

    the terminal tells me the following

    x@x-ThinkCentre-A58:/usr/share$ gcc -v
    Using built-in specs.
    COLLECT_GCC=gcc
    COLLECT_LTO_WRAPPER=/usr/lib/gcc/i686-linux-gnu/4.8/lto-wrapper
    Target: i686-linux-gnu
    Configured with: ../src/configure -v --with-pkgversion='Ubuntu 4.8.2-19ubuntu1' --with-bugurl=file:///usr/share/doc/gcc-4.8/README.Bugs --enable-languages=c,c++,java,go,d,fortran,objc,obj-c++ --prefix=/usr --program-suffix=-4.8 --enable-shared --enable-linker-build-id --libexecdir=/usr/lib --without-included-gettext --enable-threads=posix --with-gxx-include-dir=/usr/include/c++/4.8 --libdir=/usr/lib --enable-nls --with-sysroot=/ --enable-clocale=gnu --enable-libstdcxx-debug --enable-libstdcxx-time=yes --enable-gnu-unique-object --disable-libmudflap --enable-plugin --with-system-zlib --disable-browser-plugin --enable-java-awt=gtk --enable-gtk-cairo --with-java-home=/usr/lib/jvm/java-1.5.0-gcj-4.8-i386/jre --enable-java-home --with-jvm-root-dir=/usr/lib/jvm/java-1.5.0-gcj-4.8-i386 --with-jvm-jar-dir=/usr/lib/jvm-exports/java-1.5.0-gcj-4.8-i386 --with-arch-directory=i386 --with-ecj-jar=/usr/share/java/eclipse-ecj.jar --enable-objc-gc --enable-targets=all --enable-multiarch --disable-werror --with-arch-32=i686 --with-multilib-list=m32,m64,mx32 --with-tune=generic --enable-checking=release --build=i686-linux-gnu --host=i686-linux-gnu --target=i686-linux-gnu
    Thread model: posix
    gcc version 4.8.2 (Ubuntu 4.8.2-19ubuntu1)

    Can anybody please tell me how to configure QT to use this as the compiler?
    thank you very much in advance

    Edit:
    Just adding this to clarify the subject:
    I do know how to set up a compiler in QT
    the problem is the gcc cannot be found via tools-options-etc. in QT although it has been properly installed


  • Lifetime Qt Champion

    Hi and welcome to devnet,

    You shouldn't need to do anything special. Do you have any problem ?



  • Hi and thanks for the welcome,
    well i do have the problem that i can not use QT without compiler.

    Where is the compiler located?
    I have no idea and tried everything possible by searching, but nothing.
    All this sudo-whatsoever-voodoo for the installation didn't give me the slightest hint where the GCC compiler is located, but it is obviously working as the console command gcc -v shows.

    But where???

    Is it hidden because i need admin rights to find it? or which magic do i have to add to be able to make it visible to QT?
    Please help.


  • Moderators

    @developSomething
    I love your term "sudo-whatsoever-voodoo". :D
    Being also a windows user I am completely understanding your frustration. However, sudo-stuff seem to be also under linux the only reliable way to do things in a similar way across different versions. Especially also Ubuntu as probably also other distributions follow the stupid MS windows path in changing permanently the look and feel of their products. Some people might enter into higher emotional spheres when discovering completely changed colors, shapes and text entries. However, exactly that bbecomes a nightmare for those trying to get things done.

    The compiler must be installed in one of the typical locations (see e.g.) The naming of those folders are contracdicting the normal human sense of windows users for a couple of decades now.

    At the day''s end I found that it is not really essential to know exactly where your compiler is installed.

    Yes, you need to have root rights for installation. There should be typically an "software update center" or something similar to allow you to do installation of different apps. Unforunately I cannot boot 14.04 to check the proper name. In a previous version is was called "Ubuntu Software Center".
    After mastering the banality to find this, it is IMO straight forward to add the installation of GCC by using the search functionality.

    When your terminal does not find gcc or only an older version than you require, you need to install a new version.
    Hope that helps!



  • @koahnig

    Hi and thanks for your answers.
    At least i have found the directory where gcc is installed on my system. it is in /usr/bin/
    Of course there are several different versions available, it seems gcc-4.8 is the best bet. So first step is: hooray! it is found!
    But only by me as the poor little human in front of the monitor.
    Not by Qt!

    Qt constantly refuses my choice for the compiler!
    It is impossible to select it!

    I have uninstalled Qt twice and reinstalled to a different location, hoping for the miracle it might discover the installed gcc automagically, but No! No matter what i try the compiler gets constantly ignored.
    so no matter which kit i choose or try to edit by selecting the installed gcc into it i ALWAYS get only the error message when setting up a project

    "Fehler: im Kit ist kein Compiler eingerichtet"
    Thanks to the QT-Installer i cannot choose another language but german, like for example english for my installation. It is not allowed for me.
    So the transaltion for the forum is:
    Error: there is no compiler set up in the kit

    whenever i set up the compiler in whichever kit it gets selected without any error or hint and then silently removed again.
    whoooosh...wiped out
    funny

    What the F*** do i have to do to make QT use the compiler?
    Instead of ignoring it?


  • Moderators

    @developSomething
    You might want to check if there is no more recent compiler in the repository. Actually you find on this page gcc 4.9. Since you are using Qt 5.4.1 this might be the reason for your problems since it is compiled apparently with gcc 4.9. Therefore, it rejects gcc 4.8.

    The language looks more like a Qt creator setting. In the English version you have under "Options"->"Environment" the possibility to change the language used. I hate the translations to German as well and switch as fast as possible to English. ;)

    When you repository does not include gcc 4.9 there are ways to install another version of gcc when it is only available outside of repro.
    However, from personal experience I know that you are typically starting a "life-long" battle with your system, when you start to change those things. My personal rating is that those kind of manipulations are more for linux masochists loving cryptic line commands. Nothing really for windows boys like us.

    I would recommend rather downloading and using the previous version of Qt or upgrading Ubuntu.



  • @koahnig
    It is hooray again!
    Now with gcc-4.9 my choice is both allowed and accepted.
    I have a real compiler in QT set up now!

    Next problem:
    the build stops with the following error:
    g++: command not found

    My guess is it is about the qmake build step which is as following
    qmake: qmake testwin.pro -r -spec linux-g++ CONFIG+=debug


  • Lifetime Qt Champion

    Let's add some voodoo:
    sudo apt-get install build-essential



  • @SGaist
    my voodoo capabilities did not succeed
    here is the result:
    Paketlisten werden gelesen... Fertig
    Abhängigkeitsbaum wird aufgebaut.
    Statusinformationen werden eingelesen.... Fertig
    E: Paket build-essential kann nicht gefunden werden.

    translation:
    the package build-essential can not be found


  • Lifetime Qt Champion

    Was ? Oo

    That's something pretty strange then…

    You can find it listed here

    Do you have a special install of Ubuntu Trusty ?

    In any case, you can also just call sudo apt-get install g++ but still it's puzzling



  • @SGaist
    Now the compiler g++ is installed and working!
    Third hooray!

    But the first testproject build stops with the issue:
    cannot find -lGL


  • Lifetime Qt Champion

    That one has been covered many times in this forum: you are missing the OpenGL dev library

    sudo apt-get install libgl1-mesa-dev



  • @SGaist
    It is the same result as above
    Paketlisten werden gelesen... Fertig
    Abhängigkeitsbaum wird aufgebaut.
    Statusinformationen werden eingelesen.... Fertig
    E: Paket libgl1-mesa-dev kann nicht gefunden werden.

    I dont know if it has to do wih my Ubuntu 14.04LTS, i downloaded the official iso and made a dvd from it to install on my Lenovo PC
    so it should be a normal installation?!

    And a more general question: isn't there a more complete package for qt-installation? I mean this is really the hard way to get one error fixed after the other. One surprise follows the next.
    I mean without your help i wouldn't be able to get anything done within weeks?!


  • Moderators

    @developSomething
    No, there no more complete packages available.
    You are struggling with the different components of your linux distro. They may be depend on each distro and have licenses. This cannot be easily distributed within one package. Unfortunately, it is the same as with windows.


  • Lifetime Qt Champion

    One thing you can do that might help is to install the dev packages of Qt from Ubuntu's repository but at this point there seems to be strange things going on. Not finding build-essential is really not normal, what sources does apt use to retrieve the packages ?



  • this is what the terminal shows:

    x@x-ThinkCentre-A58:~$ apt
    apt 1.0.1ubuntu2 für i386, kompiliert am Oct 28 2014 20:57:14
    Usage: apt [options] command
    CLI for apt.
    Basic commands:
    list - list packages based on package names
    search - search in package descriptions
    show - show package details
    update - update list of available packages
    install - install packages
    remove - remove packages
    upgrade - upgrade the system by installing/upgrading packages
    full-upgrade - upgrade the system by removing/installing/upgrading packages
    edit-sources - edit the source information file


  • Lifetime Qt Champion

    What does apt-cache search build-essential return ?


  • Lifetime Qt Champion

    Also, what do you have in /etc/apt/sources.list ?



  • @SGaist
    What does apt-cache search build-essential return ?

    It returns nothing.

    and this is the content of /etc/apt/sources.list:

    # deb cdrom:[Ubuntu 14.04.2 LTS _Trusty Tahr_ - Release i386 (20150218.1)]/ trusty main restricted
    
    # See http://help.ubuntu.com/community/UpgradeNotes for how to upgrade to
    # newer versions of the distribution.
    
    ## Major bug fix updates produced after the final release of the
    ## distribution.
    
    ## N.B. software from this repository is ENTIRELY UNSUPPORTED by the Ubuntu
    ## team. Also, please note that software in universe WILL NOT receive any
    ## review or updates from the Ubuntu security team.
    
    ## N.B. software from this repository is ENTIRELY UNSUPPORTED by the Ubuntu 
    ## team, and may not be under a free licence. Please satisfy yourself as to 
    ## your rights to use the software. Also, please note that software in 
    ## multiverse WILL NOT receive any review or updates from the Ubuntu
    ## security team.
    
    ## N.B. software from this repository may not have been tested as
    ## extensively as that contained in the main release, although it includes
    ## newer versions of some applications which may provide useful features.
    ## Also, please note that software in backports WILL NOT receive any review
    ## or updates from the Ubuntu security team.
    
    
    ## Uncomment the following two lines to add software from Canonical's
    ## 'partner' repository.
    ## This software is not part of Ubuntu, but is offered by Canonical and the
    ## respective vendors as a service to Ubuntu users.
    # deb http://archive.canonical.com/ubuntu trusty partner
    # deb-src http://archive.canonical.com/ubuntu trusty partner
    
    ## This software is not part of Ubuntu, but is offered by third-party
    ## developers who want to ship their latest software.
    deb http://extras.ubuntu.com/ubuntu trusty main
    deb http://archive.ubuntu.com/ubuntu trusty restricted
    deb-src http://extras.ubuntu.com/ubuntu trusty main
    

  • Lifetime Qt Champion

    Silly question but did you run apt-get updateafter you installed your system ?



  • Now that i have tried everything mentioned another idea came to my mind:

    Could it be possible it is my IP which is disliked by ubuntu? therefor only offering certain packages, excluding dev?

    (moderation comment: we don't think there is a global conspiracy on Ubuntu packages, and looks like the problem was solved below)


  • Moderators

    Hi,

    @developSomething said:

    and this is the content of /etc/apt/sources.list:

    I see that you don't have any official repositories available. See https://help.ubuntu.com/community/Repositories/Ubuntu to add them. (At the very least, you need the "Main" repository. I also suggest adding "Universe" and "Restricted" to make Ubuntu nicer to useable.)

    Then, try downloading the packages again.

    isn't there a more complete package for qt-installation? I mean this is really the hard way to get one error fixed after the other. One surprise follows the next.

    I've been using Ubuntu as a secondary computer for many years now. All this while, the only things I've needed to do to develop with Qt on Ubuntu are:

    1. Install Ubuntu
    2. Install g++
    3. Install OpenGL development libraries (Mesa)
    4. Install Qt

    You're having difficulties because your machine has been misconfigured somewhere. (Usually,some repositories are enabled by default as soon as you install Ubuntu.)

    Maybe this is kind of a location-based-service, meaning, well...
    In my neighborhood there are living a lot of people from all over the world, including many muslims.
    Could it be possible it is my IP which is disliked by ubuntu? therefor only offering certain packages, excluding dev?

    Given that Canonical wants Ubuntu to spread all over the world, I'd be very surprised if they did this. However, you could ask at https://askubuntu.com to verify.

    Anyway, I don't see how Muslims are related to your issue.



  • @JKSH
    thanks to your little install guide now everything works fine!

    all i had to do was remove the whole ubuntu installation and restart from scratch.

    Surprisingly the repositories were all set up correctly by default, maybe it was because i have chosen the default US-english installation instead of the german one ..^^

    I would even be willing to add SOLVED to the title of the thread
    if only i knew how to?


  • Moderators

    @developSomething
    How to mark as solved?

    Simply go to the first post where you started. Press the gear wheel on the very right and select the left (Edit) symbol.
    Go to your title line. Add there [solved] in the beginning of line.


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.