Qt Creator - Tab Settings - Insert tab character even when configured for spaces



  • Using Qt Creator 3.3.2 with Qt 5.4.1 on Ubuntu 14.04

    My preference is to always replace tabs with spaces. When I press tab, it should replace with spaces. It does this just fine.

    Sometimes I'll edit files that are sensitive to tabs though; for example Makefiles or Python or maybe I just want to keep an existing file's tab type.

    I noticed with Python files if I press tab one it will add spaces. If I press it again it will convert the spaces back to a tab. But it doesn't do this for other types of files.

    Is there a way to add a modifier key which disables changing tabs to spaces? Say for example pressing tab alone should respect the editor's tab settings. But pressing tab with a modifier key(s) ignores tab settings and simply inserts a raw tab character?

    The only way I've come up so far is to copy a tab from somewhere and paste it in. However this is obviously inconvenient because it uses up my clipboard and I'd have to have a tab available to copy (which means opening a different file if I wanted to start a new file).


  • Lifetime Qt Champion

    Hi and welcome to devnet,

    This is something you should check with the Qt Creator team. You should bring this to the qt-creator mailing list You'll find there Qt Creator's developers/maintainers (this forum is more user oriented)


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.