[SOLVED] QT and boost : cannot find -llibboost_filesystem...



  • Hi,

    I work with (and I cannot an other version of Qt) :

    • QT Creator 2.4.1 and QT 4.8.4 (with Mingw compiler)
    • boost 1.52

    To build boost :

    • i first added "C:/Qt/qtcreator-2.4.1/mingw/bin" to my PATH variable
    • then opened a command prompt
    • went to "C:/boost_1_52"
    • typed "bootstrap.bat mingw"
    • and then "b2 toolset=gcc build-type=complete stage" (this took a long time (about 2h))

    I would like to use QT creator with the boost library but I come up against difficulties.
    My project is very simple, it's only basic QT code :

    QCoreApplication a(argc, argv) 
    return a.exec()
    

    I just added some includes :

    #include <boost/thread.hpp>
    #include <boost/property_tree/json_parser.hpp> 
    #include <boost/asio.hpp>
    #include <boost/thread.hpp>
    

    In my .pro file I have added :

    INCLUDEPATH += C:/boost_1_52
    LIBS += -L$quote(C:/boost_1_52/stage/lib) \
    -llibboost_filesystem-mgw48-mt-d-1_52 \
    -llibboost_system-mgw48-mt-d-1_52
    

    When I run qmake and then try to build my project it fails with the error

    cannot find -llibboost_filesystem-mgw48-mt-d-1_52
    collect2: ld returned 1 exit status
    

    I tried to replace "-llibboost_filesystem..." with "-lboost_filesystem..." but it does the same.

    I checked and I have got these to files in the C:/boost_1_52/stage/lib
    (actually I have 3 "libboost_filesystem-mgw48-mt-d-1_52" : one .a, one .dll and one .dll.a) (it's the same for "libbost_system-mgw48-mt-d-1_52")

    If I remove the "-llibboost_filesystem..." and "-llibboost_system..." I've got multiple errors like

    "undefined reference to WSAStartup@8"
    "undefined reference to boost::system::generic_category()"
    

    Thank you in advance for your help.



  • On a general note, I would always discourage the simultaneous usage of boost and Qt. It makes the code inconsistent, boost in general is more error-prone than the corresponding Qt classes and it is duplicating functionality. Qt is an application development framework, not a GUI library.

    While it is technically possible, it is really awkward in design. Many beginners make that mistake.



  • Unfortunately I am working on a project that has been started by someone else and so I have no choice but using Qt and Boost.

    I forgot to say that when I built boost, it said
    "failed updating 32 targets"
    "skipped 64 targets
    "updated 4599 targets"

    I do not know if this is normal or not



  • Hi zarachbaal,

    for your includes

    #include <boost/thread.hpp>
    #include <boost/property_tree/json_parser.hpp> 
    #include <boost/asio.hpp>
    #include <boost/thread.hpp> 
    

    you dont need boost_filesystem. Asio generates the errors.

    "undefined reference to WSAStartup@8"
    "undefined reference to boost::system::generic_category()"
    

    Asio needs to be link against to additional libraries. Add to your LIBS +=
    1.) Boost_system: -LC:/path/to/boost/libs and -llibboost_system-mgw48-mt-1_52
    2.) On Windows, WS2_32.lib: -LC:/path/to/winsock2/lib and -lWS2_32

    This is tested with boost 1_57 and mingw49 on my win7 system.
    Hope it helps.



  • The errors about WSAStartup@8, WSACleanup@0... disappeared, that's a start !

    But I still have a bunch of undefined reference errors.
    A lot have "thread" in their name like :

    undefined reference to `_imp___ZN5boost6threadC1Ev'
    undefined reference to `_imp___ZN5boost6thread4joinEv'
    

    So I guess I also have to add the 'libboost_thread-mgw48-mt-1_52' library ?
    But I only have '.a' files in 'stage/lib' (no '.dll" or '.dll.a' files), and if I do '-llibbost_thread-mgw48-mt-1_52' it says it cannot find the library
    Maybe the lack of '.dll' and '.dll.a' is due to the 'failed updating 32 targets' when I built boost ?

    Also, I still have some
    undefined reference to boost::system::generic_category()
    undefined reference to boost::system::system_category()



  • I forgot to say, that I had to reorder the header includes to get a build.

    #include <boost/asio.hpp>
    #include <boost/property_tree/json_parser.hpp>
    #include <boost/thread.hpp>
    


  • I can only suggest you talk with the one introducing boost (if you have to) and see whether you can get rid of it for obvious reasons. You will save yourself a lot of unnecessary work. Before trying that, I wouldn't investigate too much, this is lost time.

    Other than that, I am out here.



  • @cybercatalyst
    I agree, but this wont solve the problem.



  • It does solve the problem, because you the errors you see are linker errors caused by boost. If you just stick to the Qt classes like intended, you will not have those.


  • Lifetime Qt Champion

    @zarachbaal said:

    undefined reference to `_imp___ZN5boost6threadC1Ev

    Hi,

    You're not linking to the boost_thread library.

    You missing something like:
    LIBS += -lboost_thread-mgw48-mt-1_52
    or similar



  • @cybercatalyst :

    In fact I'm using the EyeTribe eye tracking device and the SDK uses the boost library.
    So I have no choice but using it.



  • No offense, but in that case you should contact their support instead asking here. I hope you understand, this is not something the community could/should help you with as the source of problems clearly is the usage of boost.

    (in the sense to make them aware of their fault, you should request them to fix it)



  • @cybercatalyst

    Using boost and qt together is not uncommon. There are indeed some libraries in boost that have no equivalent replacement in qt. Sure this seems not to be a qt issue, but if you do not want to help, just leave it. I for one, as part of the community saved a lot of time looking at posts like this. And by the way the valuable answers have never been something like "dont do that" or "ask someone else".



  • @SGaist :

    I added "-lboost_thread-mgw48-mt-1_52" at the end of my "LIBS +=..." line.
    It finds the library but I still have those errors...

    I also changed the order of my includes as sneubert suggested but that did not help

    @cybercatalyst :

    I will contact them about this but I have to make it work on Qt for the next week...



  • @sneubert said:

    Using boost and qt together is not uncommon.

    Yes, you are right! And it's the source for a whole bunch of unnecessary issues. That's why I find it important to state it's the wrong way to go. The fact that boost and qt are being used side-by-side comes from the misconception that people want to somehow get rid of Qt on non-GUI code in lower level stuff because Qt is GUI-only. This is very bad and it's important to remind that Qt is an application framework.

    This is the only reason I am writing this and if it makes people to rethink then this has been very useful imo.


  • Lifetime Qt Champion

    Did you check that the library name is correct ? I've based it on the ones you're already using so I might have missed something



  • @SGaist :

    Yes I checked and the library is here, i even copy/pasted the name to be sure
    Qt does find the library, if I enter a wrong library name it gives an error (error : cannot find "false_library_name")

    As I said before I only have "libboost_thread-mgw48-mt-1_52.a" file.
    When I had '.a', '.dll' and '.dll.a' files for "libboost_system..."

    Maybe it has something to do about it ?


  • Lifetime Qt Champion

    You can try adding DEFINES += BOOST_THREAD_USE_LIB



  • @SGaist :

    I just added your code, unfortunately it has no effect on the errors.



  • I checked my boost lib dir and I do have a libboost_thread-mgw... .dll and .lib so maybe you investigate the build of the boost libraries.



  • @sneubert :

    I downloaded and built boost 1.58.
    This time I do have '.a', '.dll' and '.dll.a' for libbost_thread...
    But it does not change anything

    I don't recall doing anything in particular but the errors about 'thread' are not the same anymore.
    They were like :
    undefined reference to _imp___ZN5boost6threadC1Ev'
    undefined reference to _imp___ZN5boost6thread4joinEv'

    And now :
    undefined reference to boost::thread::thread()'
    undefined reference to boost::thread::joinable() const'

    I just noticed that I have another error :
    cc1plus.exe:-1: erreur : note: initialized from here
    file not found : cc1plus.exe



  • cc1plus.exe is the cpp compiler invoked by gcc.
    Do you have another MinGW installation on your system?
    Maybe you have some references in your local or global PATH
    environment variable pointing to the wrong MinGW bin dir?



  • I have MinGW installed in C:/MinGW
    And also the one that comes with Qt Creator.

    In my PATH I have set "C:\Qt\qtcreator-2.4.1\mingw\bin"

    Nevermind, this error appeared because I changed the MinGW to use in Project options.
    If I select the MinGW that comes with Qt Creator this error disappears.



  • I may have an idea why it's not working.
    I did not see, but I had Strawberry perl installed and it has mingw.
    In my path I had "C:\Strawberry\c\bin" set, so I built boost using this mingw (v4.8.1) and the mingw that comes with Qt creator is v4.4.0

    I removed strawberry from the path.
    I am currently rebuilding boost with the correct mingw, will update tomorrow.



  • I´m curious about it.


  • Lifetime Qt Champion

    Never modify PATH when you are developing (it should also be avoided as much as possible the rest of the time), it's in the same category as developing as root on linux ;)

    More seriously, having MinGW or the Qt bin path in your PATH is an open door to a world of problem since you will be thing you are using one version of a library while in fact using another one. Also, MinGW isn't always compatible between two versions of their compiler. That's probably why you had problem in the first place since you where using two different versions.

    In any case, one rule that you should apply on Windows: Use the same compiler for all your code and dependencies. It's not always possible but it will greatly simplify your life.



  • That was it, it works fine now !

    @SGaist : I did not notice in the first place that I was using two versions of MinGW.
    When I installed Strawberry some weeks ago he added himself his path to the environement variable PATH.
    So I thought I was compiling boost with the MinGW from Qt Creator, I did not pay enough attention to the 'mg48' in librairies' name that should have been 'mg44'.

    How do I make this subject "solved" ?


  • Lifetime Qt Champion

    Windows can be tricky for that

    IF you don't have the option in the Topic Tools menu, just edit the thread title and prepend [solved]



  • OK, thank you all for your help :)


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.