Debug Assertion Failed !



  • Hello,

    """""when i put two statements QEventLoop loop and loop.exec();""""" as in the following code; one of my problem of slot not getting executed for "SIGNAL(finished(QNetworkReply*));" got solved..

    but it lead to a new error which was "Debug Assertion Failed !" displayed on a window...it said line 52 but at that line there is no code.. after this line is "connect(&manager, SIGNAL(finished(QNetworkReply*)),SLOT(downloadFinished(QNetworkReply*)));".

    However on pressing the button to debug on that window of "Debug Assertion Failed" it went to VS blank screen.

    On selecting "Break All" from the menu, it opened a file "free.c" and went to a line "retval = HeapFree(_crtheap, 0, pBlock);.. " but I don't find assert anywhere in this file...why am I getting such an error...

    Some Code lines: @

                            QEventLoop loop;
    
    
                         qDebug()<<"In doDownload";
    
                       QNetworkReply*reply = manager.get(request);
    
    
                       loop.exec(&#41;;
                @


  • Please, reformat your question and code so it becomes readable. Use @ tags around code sections, and use proper points, commas, newlines and capitalization for running text. Currently, it is not readable at all.

    You can use the edit link that is to the right of the message you posted to modify it.



  • is it now formatted enough...if it is please let me know the answer..



  • I got this solved but now I'm having another problem...
    I am calling a function in which I'm setting the URL and signal & slots..the slot definitions and this function where setting the slot are in a file and I'm calling the function from another file. However after the execution of slot correctly the control doesn't come back to the file from where the function was called. If I close the simulator then only the control comes back to another file and debug statements there are executed...why is is so...



  • Ashwin already posted the second question as a separate query "here":http://developer.qt.nokia.com/forums/viewthread/5048/. Please take the discussion to that thread instead. Since there are no more problems to solve in this thread, I closed it.


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.