Qt 5.4.0 iOS Code Signing Error while compiling (Qt Source)



  • Hi,

    I hope someone can help me with this issue I have. I am trying to compile the Qt 5.4.0 Beta Source on a Mac OS X 10.9.4 with XCode 5.1.1 installed and I always get the same Build Error.

    I used this configuration:

    @./configure -opensource -xplatform macx-ios-clang -release -sdk iphoneos -nomake tools -nomake examples -nomake tests@

    I always end up with this error message while trying to 'make':

    @Check dependencies
    Code Sign error: No matching provisioning profiles found: No provisioning profiles with a valid signing identity (i.e. certificate and private key pair) were found.

    ** INSTALL FAILED **

    The following build commands failed:
    Check dependencies
    (1 failure)
    make[4]: *** [iphoneos-release-install] Error 65
    make[3]: *** [iphoneos-install] Error 2
    make[2]: *** [sub-xmlpatterns-install_subtargets] Error 2
    make[1]: *** [sub-tools-install_subtargets] Error 2
    make: *** [module-qtxmlpatterns-install_subtargets] Error 2@

    After searching I tried a lot, but the only information that helped me finishing 'make' was:

    http://qt-project.org/forums/viewthread/49420

    So I exported the developer identity and it successfully finished 'make'. Now I tried 'sudo make install' and it's stuck with the same error message you can see above. I also tried Qt 5.3.0 Source Release and Qt 5.4.0 Source Alpha but I always end up with the same error message.

    I appreciate any help.

    berbande



  • Does someone has any idea why this error is showing up?


  • Lifetime Qt Champion

    Hi and welcome to devnet,

    Good question, I can currently only offer a workaround: install your custom built Qt in a path where you have write access.



  • Thank you SGaist. I have write access to the folder where Qt is located. The message appears about 3 to 4 minutes after the start of 'sudo make install' so i think if it has no write access this message would show up earlier.


  • Lifetime Qt Champion

    Then why are you calling make install with sudo if you already have write access to the folder where you want to install Qt ?


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.