[solved] Code signing error - Compiling Qt 5.4 for iOS



  • Hi,

    i try to compile Qt 5.4 from git static with open ssl support.
    This is my configure:
    @./configure -nomake examples -nomake tests -openssl-linked -I/development/libs/openssl-1.0.1j/include -L/development/libs/openssl-1.0.1j/lib -lcrypto -lssl -xplatform macx-ios-clang -debug-and-release -confirm-license -static -skip qtwebkit -skip qtserialport -skip qtwebkit-examples -prefix /development/Qt/5.4.0-git-ssl-static-ios@

    I also have latest Xcode installed and added my apple developer account.

    Somehow i get the following error about code signing:

    @=== BUILD TARGET xmlpatterns OF PROJECT xmlpatterns WITH CONFIGURATION Debug ===

    Check dependencies
    Code Sign error: No code signing identities found: No valid signing identities (i.e. certificate and private key pair) matching the team ID “(null)” were found.
    CodeSign error: code signing is required for product type 'Application' in SDK 'iOS 8.1'

    ** BUILD FAILED **

    The following build commands failed:
    Check dependencies
    (1 failure)
    make[4]: *** [iphoneos-debug] Error 65
    make[3]: *** [iphoneos] Error 2
    make[2]: *** [sub-xmlpatterns-make_first] Error 2
    make[1]: *** [sub-tools-make_first] Error 2
    make: *** [module-qtxmlpatterns-make_first] Error 2
    @

    How to tell Qt to use correct identity?

    Greetings
    Nando



  • Ok, now it works.

    think the problem was because it occurred on a new mac os x installation.
    i removed all my developer identities and provisioning profiles on my mac box (they were synced after connecting to my apple account from old mac box).

    then i resynced the stuff from Xcode (in account section)

    Now it works.

    Greetings
    Nando



  • I just experienced this same error trying to build an app I hadn't built for a long time with new versions of QtCreator and Xcode (Qt 5.4.1 and Xcode 6.2).

    What I did was:

    • Open Xcode
    • Go to Xcode > Preferences...
    • Select 'Accounts'
    • Click the 'View Details...' button at the bottom right of the right pane
    • In the window that pops up listing the provisioning profiles, click the refresh button at the bottom left

    After that, I rebuilt the project in QtCreator and it built cleanly straight away.



  • Have you set a team in Project Navigator under General > Identity?


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.