QWT Framework not found



  • I apologize if a question similar has already been asked and answered, but I have viewed many links but have still not been able to correct this issue.

    I am currently trying to build a project in QT that uses the Qwt library. However, when I try to build the project I get

    @
    warning: directory not found for option '-F/usr/local/qwt-6.1.0/lib'
    error:framework not found qwt
    error:linker command failed with exit code 1@

    I have followed the steps in "this":http://stackoverflow.com/questions/18588418/install-and-use-qwt-under-mac-os-xpost as well as "this":http://stackoverflow.com/questions/10540666/error-when-compiling-simple-qwt-program-on-mac-osx-10-7-4post but it still cannot find the framework

    I am using Xcode 6, Qwt 6, QT 5.3, and Mac OSX 10.9.

    My .pro file's relevant code is as follows:
    @
    #mac: QMAKE_MAC_SDK.macosx.path = Applications/Xcode.app/Contents/Developer/Patforms/MacOSX.platform/Developer/SDKs/MacOSX10.9.sdk
    #mac: QMAKE_MACOSX_DEPLOYMENT_TARGET = 10.9
    #Added to help build QWT
    #INCLUDEPATH += /usr/local/qwt-6.1.0/qwt.prf
    include (/usr/local/qwt-6.1.0/qwt.prf )
    #CONFIG += qwt

    #macx:QMAKE_MAC_SDK += macosx10.9
    QMAKEFEATURES += /usr/local/qwt-6.1.0/features
    CONFIG += qwt
    #mac:INCLUDEPATH += /Library/Frameworks/qwt.framework/Headers
    #mac: INCLUDEPATH += /usr/local/qwt-6.1.0/src
    mac: INCLUDEPATH += /usr/local/qwt-6.1.0/lib/qwt.framework/Headers
    linux-g++:INCLUDEPATH += /usr/local/qwt-5.2.1/include
    win32:INCLUDEPATH += C:/Qwt-5.2.1/include
    FORMS += ui/
    UI_HEADERS_DIR = inc_ui
    OBJECTS_DIR = obj
    MOC_DIR = moc
    #mac:LIBS += /usr/local/qwt-6.1.0/lib -framework qwt
    #mac:LIBS += -l /usr/local/qwt-6.1.0/lib/qwt.framework
    mac:LIBS += -F /usr/local/qwt-6.1.0/lib -framework qwt
    linux-g++:LIBS += /usr/local/qwt-5.2.1/lib/libqwt.so
    win32:LIBS += C:/Qwt-5.2.1/lib/qwt5.dll
    @
    Any help is appreciated,
    Thanks.


  • Lifetime Qt Champion

    Hi,

    If i'm not mistaken you have a space between -F and /usr/etc… which is wrong



  • Good Morning,

    Thank you for the reply. I fixed the spacing error, but the issue still occurs. As you could have guessed, all of the commented out lines are paths I have tried to incorporate in some way to try and find the framework.

    The "warning: directory not found for option '-F/usr/local/qwt-6.0.1/lib'" warning seems to lead me to believe that it is not recognizing the directory even though it is there. I also tried /Library/Frameworks as there is a soft link in there, but still no luck


  • Lifetime Qt Champion

    Might be a silly question, but are you sure that /usr/local/qwt-6.0.1/lib exists ?



  • Yepp, the directory does exist. Dont think I made any typos on it. In line 22 would need to add /qwt.framework after /lib and before "-framework" ?


  • Lifetime Qt Champion

    No you don't need to, what is intriguing is the it doesn't find the directory, did you check the folder rights ?



  • The folder rights look fine. From everything I have read so far it seems as if I am attempting to invoke the framework in the right way and that it just isnt finding it in the path (even though the path exists)


  • Lifetime Qt Champion

    Wait, I just realized, Xcode 6 is bringing a lot of subtle modification that are breaking things around I wonder it it's one of these.

    Can you check whether using another non-system and Qt unrelated framework also encounter that kind of problem ?



  • My apologies, but the wording of your suggestion confuses me. The Qwt framework is the only framework I am trying to use with this project, if that is what you are asking.


  • Lifetime Qt Champion

    Sorry for that. No it's not that. I was asking you (for testing purpose) to try linking to another framework (anything you like but not one of OS X's system framework and not a Qt dependent framework)


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.