[SOLVED] - Failed to compile qtwebengine - missing file



  • Hi,
    I was following instructions on https://qt-project.org/wiki/Building-Qt-5-from-Git#0cc5cbb2903cf6911ac1b6e3aa032572 to get the source code and build qt5 on my mac (10.9). However, after running 'make', i get the error below:

    /Applications/Xcode.app/Contents/Developer/usr/bin/make -f Makefile.gyp_run.Debug all
    /Users/rharchandani/Documents/gitstuff/qt5/qtwebengine/src/3rdparty/ninja/ninja -C /Users/rharchandani/Documents/gitstuff/qt5/qtwebengine/src/core/Debug
    ninja: Entering directory `/Users/rharchandani/Documents/gitstuff/qt5/qtwebengine/src/core/Debug'
    ninja: error: '../../../src/3rdparty/chromium/base/test/expectations/expectation.cc', needed by 'obj/src/3rdparty/chromium/base/test/expectations/test_support_base.expectation.o', missing and no known rule to make it
    make[5]: *** [invoke_ninja] Error 1
    make[4]: *** [debug-all] Error 2
    make[3]: *** [sub-gyp_run-pro-make_first] Error 2
    make[2]: *** [sub-core-make_first] Error 2
    make[1]: *** [sub-src-make_first] Error 2
    make: *** [module-qtwebengine-make_first] Error 2

    Is there something i am missing?

    Thanks,
    Rohit


  • Lifetime Qt Champion

    Hi,

    Please check that you are using the dev branch and try again



  • Thanks..i was using the dev branch. the problem was that everything from the bin directory of my local Qt 5.3 install was on the PATH..once i removed it and tried to build it, it worked fine.


  • Lifetime Qt Champion

    Good !

    Since it's working now please update the thread title prepending [solved] so other forum users may know as solution has been found :)


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.